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Server Options 

Intel® Server Board S5520HC 

Quantity Item Manufacturer Model 

1 Intel® Server Board S5520HC Intel S5520HC 

1 Intel® Server Chassis Intel SC5600, SC5650 or third-party 

24 GB or 
more 

Memory modules Any supported Refer to the tested memory list at 
http://www.intel.com/support/motherboa
rds/server/s5520hc/sb/CS-030221.htm 

2 per server Intel® Xeon® processors Intel Refer to the tested processor list at 
http://www.intel.com/support/motherboa
rds/server/sb/CS-030213.htm  

1  SATA/SAS hard drives or SSD THOL Refer to the tested hardware list at 
http://www.intel.com/support/motherboa
rds/server/s5520hc/sb/CS-030220.htm 

1 per server 
(optional) 

Integrated RAID I/O Expansion Module 
AXXROMBSASMR 
(Internal 4-port SAS RAID ROC module) 

Intel AXXROMBSASMR 
http://ark.intel.com/Product.aspx?id=51
239  

1 (optional) 

 

Intel® RAID Controller AXX4SASMOD 
(Internal 4-port SAS module) 

Intel AXX4SASMOD  
http://www.intel.com/products/server/rai
d/index.htm  

1 (optional) Intel® Ethernet X520 Server Adapter  Intel X520 (10Gb Ethernet adapter) 
http://www.intel.com/Products/Server/A
dapters/X520/ethernet-X520-
overview.htm  

1 (optional) Intel® Gigabit ET2 Quad Port Server 
Adapter 

Intel ET2 
http://ark.intel.com/Product.aspx?id=49
187  

 BIOS 54; BMC 54 or greater Intel  

Table 1:  Intel® Server Board S5520HC Hardware Configuration 

  

http://www.intel.com/support/motherboards/server/s5520hc/sb/CS-030221.htm
http://www.intel.com/support/motherboards/server/s5520hc/sb/CS-030221.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/s5520hc/sb/CS-030220.htm
http://www.intel.com/support/motherboards/server/s5520hc/sb/CS-030220.htm
http://ark.intel.com/Product.aspx?id=51239
http://ark.intel.com/Product.aspx?id=51239
http://www.intel.com/products/server/raid/index.htm
http://www.intel.com/products/server/raid/index.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://ark.intel.com/Product.aspx?id=49187
http://ark.intel.com/Product.aspx?id=49187
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Intel® Server Board S5520UR 

Quantity Item Manufacturer Model 

1 Intel® Server Board S5520UR Intel S5520UR 

1 
 
 
 

Intel® Server System 
(1U) 3.5” disk drive 
-Or- 
Intel® Server System 
(1U) 2.5” disk drive 
-Or- 
Intel® Server System 
(2U) 3.5” disk drives  
-Or- 
Intel® Server System 
(2U) 2.5” disk drives 

Intel SR1600UR  
 
 
SR1625UR 
 
 
SR2600UR  
 
 
SR2625UR  
 

24 GB or more Memory modules THOL Refer to the tested memory list at 
http://www.intel.com/support/motherboa
rds/server/s5520ur/sb/CS-030026.htm 

2  

 

Intel® Xeon® processors Intel Refer to the tested processor list at 
http://www.intel.com/support/motherboa
rds/server/sb/CS-030213.htm 

1 per server 
(optional)  

Active SAS backplane, located in 
chassis. RAID 0/1/1E/10 

Intel Active SAS backplane part of the 
chassis options   

1 per server 
(optional) 

 

Intel® RAID Activation Key 
AXXRAKSAS2 for 1078 ROC RAID 
0/1/5/6 and spans 10/50/60, located 
in the chassis 

Intel AXXRAKSAS2 

1 SATA/SAS hard drives or SSD THOL Refer to the tested hardware list at 
http://www.intel.com/support/motherboa
rds/server/s5520ur/sb/CS-030027.htm 

1 (optional) Intel® Ethernet X520 Server 
Adapter (10Gb Ethernet adapter) 

Intel X520 
http://www.intel.com/Products/Server/A
dapters/X520/ethernet-X520-
overview.htm  

1 (optional) Dual Gigabit Ethernet I/O Expansion 
Module AXXGBIOMOD  

Intel AXX4GBIOMOD 
http://ark.intel.com/Product.aspx?id=51
233  

 BIOS 54; BMC 54 or greater Intel  

Table 2:  Intel® Server Board S5520UR Hardware Configuration 

 

 

  

http://www.intel.com/support/motherboards/server/s5520ur/sb/CS-030026.htm
http://www.intel.com/support/motherboards/server/s5520ur/sb/CS-030026.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/s5520ur/sb/CS-030027.htm
http://www.intel.com/support/motherboards/server/s5520ur/sb/CS-030027.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://ark.intel.com/Product.aspx?id=51233
http://ark.intel.com/Product.aspx?id=51233
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Intel® Server Board S5500WB 

Quantity Item Manufacturer Model 

1 Intel® Server Board S5500WB Intel S5500WB 

1 Intel® Server System Intel SR1690WB 

24 GB or 
more 

Memory modules THOL Refer to the tested memory list at 
http://www.intel.com/support/motherboar
ds/server/s5500wb/sb/CS-030648.htm 

2 Intel® Xeon® processors Intel Refer to the tested processor list at 
http://www.intel.com/support/motherboar
ds/server/S5500WB/sb/CS-030205.htm 

1 (optional) Integrated RAID I/O Expansion Module 
AXXROMBSASMR 
(Internal 4-port SAS RAID ROC module) 

Intel AXXROMBSASMR 
http://ark.intel.com/Product.aspx?id=512
39  

1 (optional) Intel® RAID Controller AXX4SASMOD 
(Internal 4-port SAS module) 

Intel AXX4SASMOD  
http://www.intel.com/products/server/raid
/index.htm  

1 Minimum 
Non RAID 
SAS or 
SATA 

SATA/SAS hard drives or SSD THOL Refer to the tested hardware list at 
http://www.intel.com/support/motherboar
ds/server/S5500WB/sb/CS-030203.htm 

3 minimum 
Hardware 
RAID 

SATA/SAS hard drives or SSD THOL Refer to the tested hardware list at 
http://www.intel.com/support/motherboar
ds/server/S5500WB/sb/CS-030203.htm 

1 (optional) Dual Gigabit Ethernet I/O Expansion 
Module AXXGBIOMOD  

Intel AXX4GBIOMOD 
http://ark.intel.com/Product.aspx?id=512
33  

1 (optional) Intel® Ethernet X520 Server Adapter 
(10Gb Ethernet adapter) 

Intel X520 
http://www.intel.com/Products/Server/Ad
apters/X520/ethernet-X520-
overview.htm  

 BIOS 54; BMC 54 or greater Intel  

Table 3: Intel® Server Board S5500WB Hardware Configuration 

 

  

http://www.intel.com/support/motherboards/server/s5500wb/sb/CS-030648.htm
http://www.intel.com/support/motherboards/server/s5500wb/sb/CS-030648.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030205.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030205.htm
http://ark.intel.com/Product.aspx?id=51239
http://ark.intel.com/Product.aspx?id=51239
http://www.intel.com/products/server/raid/index.htm
http://www.intel.com/products/server/raid/index.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030203.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030203.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030203.htm
http://www.intel.com/support/motherboards/server/S5500WB/sb/CS-030203.htm
http://ark.intel.com/Product.aspx?id=51233
http://ark.intel.com/Product.aspx?id=51233
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
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Intel® Server Board S5500BC 

Quantity Item Manufacturer Model 

1 Intel® Server Board S5500BC Intel S5500BC 

1 Intel® Server Chassis Intel SR1630BC or SC5650 

16 GB or more Memory modules Any supported Refer to the tested memory list at 
http://www.intel.com/support/motherboards/
server/s5500bc/sb/CS-030211.htm 

2 Intel® Xeon® processors Intel Refer to the tested processor list at 
http://www.intel.com/support/motherboards/
server/sb/CS-030213.htm 

1 Minimum SATA hard drives or SSD THOL Refer to the tested hardware list at 
http://www.intel.com/support/motherboards/
server/s5500bc/sb/CS-030210.htm 

1 (optional) Intel® Ethernet X520 Server 
Adapter (10Gb Ethernet adapter) 

Intel X520 
http://www.intel.com/Products/Server/Adapt
ers/X520/ethernet-X520-overview.htm  

1 (optional) Intel® Gigabit ET2 Quad Port 
Server Adapter 

Intel ET2 
http://ark.intel.com/Product.aspx?id=49187  

 BIOS 54; BMC 54 or greater Intel  

Table 4: Intel® Server Board S5500BC Hardware Configuration 

Required System List 

Quantity Item Manufacturer Model 

1 Active Directory Domain 
Controller* 

Intel Intel® Server Boards; See Tables 1-4 

Microsoft Windows Server* 2008 R2 

1 Web/SQL Server*  Intel Intel® Server Boards; See Tables 1-4 

Microsoft IIS* 7.5 (2008 R2) 
Windows SQL Server* 2008 

1 System Center Virtual Machine 
Manager* Console 

Intel Intel® Server Boards; See Tables 1-4 

Microsoft Virtual Machine Manager* 2008 R2 

1 System Center Essentials* 
Console 

Intel Intel® Server Boards; See Tables 1-4 

Microsoft System Center Essentials* 2010 

4 or more 
(depending on 
configuration) 

Virtual Machine Hosts  Intel Intel® Server Boards; See Tables 1-4 

Microsoft Windows Server* 2008 R2 Hyper-V* 

1 iSCSI Storage Server Various Refer to the iSCSI storage recipes on the 
Intel® ESAA website  

Table 5: Required System List 

  

http://www.intel.com/support/motherboards/server/s5500bc/sb/CS-030211.htm
http://www.intel.com/support/motherboards/server/s5500bc/sb/CS-030211.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/sb/CS-030213.htm
http://www.intel.com/support/motherboards/server/s5500bc/sb/CS-030210.htm
http://www.intel.com/support/motherboards/server/s5500bc/sb/CS-030210.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://www.intel.com/Products/Server/Adapters/X520/ethernet-X520-overview.htm
http://ark.intel.com/Product.aspx?id=49187
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Software Components  

Item Version Manufacturer Comment 

Microsoft Windows Server* 2008 R2 
Hyper-V* 

2008 R2 Microsoft http://www.microsoft.com/windows
server2008/en/us/hyperv-
main.aspx 

http://technet.microsoft.com/en-
us/library/bb625087.aspx 

http://technet.microsoft.com/en-
us/library/cc753637(WS.10).aspx 

Microsoft SQL Server* 2008 R2 2008 R2 Microsoft http://www.microsoft.com/sqlserver
/en/us/default.aspx 

http://technet.microsoft.com/en-
us/library/bb545450.aspx 

Microsoft Virtual Machine Manager* 
2008 R2 

2008 R2 Microsoft http://www.microsoft.com/systemce
nter/en/us/virtual-machine-
manager.aspx - Included in 
Windows Server* 2008 R2 

Microsoft System Center Essentials* 
(SCE*) 

2010 Microsoft http://www.microsoft.com/systemce
nter/en/us/essentials.aspx 

http://technet.microsoft.com/en-
us/library/ff603627.aspx 

Microsoft VMM Self-Service Portal* 
(VMMSSP*) 

2.0 Microsoft http://tinyurl.com/29zg552 

Intel® Server Management Pack  Intel http://tinyurl.com/4eozxa6 

Intel® Server Management Agent  Intel http://tinyurl.com/47racwg 

Sanbolic* Melio FS*  Sanbolic http://www.sanbolic.com 

Table 6: Installation Software BOM 

  

http://www.microsoft.com/windowsserver2008/en/us/hyperv-main.aspx
http://www.microsoft.com/windowsserver2008/en/us/hyperv-main.aspx
http://www.microsoft.com/windowsserver2008/en/us/hyperv-main.aspx
http://technet.microsoft.com/en-us/library/bb625087.aspx
http://technet.microsoft.com/en-us/library/bb625087.aspx
http://technet.microsoft.com/en-us/library/cc753637(WS.10).aspx
http://technet.microsoft.com/en-us/library/cc753637(WS.10).aspx
http://www.microsoft.com/sqlserver/en/us/default.aspx
http://www.microsoft.com/sqlserver/en/us/default.aspx
http://technet.microsoft.com/en-us/library/bb545450.aspx
http://technet.microsoft.com/en-us/library/bb545450.aspx
http://www.microsoft.com/systemcenter/en/us/virtual-machine-manager.aspx
http://www.microsoft.com/systemcenter/en/us/virtual-machine-manager.aspx
http://www.microsoft.com/systemcenter/en/us/virtual-machine-manager.aspx
http://www.microsoft.com/systemcenter/en/us/virtual-machine-manager.aspx
http://www.microsoft.com/systemcenter/en/us/essentials.aspx
http://www.microsoft.com/systemcenter/en/us/essentials.aspx
http://technet.microsoft.com/en-us/library/ff603627.aspx
http://technet.microsoft.com/en-us/library/ff603627.aspx
http://tinyurl.com/29zg552
http://tinyurl.com/4eozxa6
http://tinyurl.com/47racwg
http://www.sanbolic.com/
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Microsoft Virtual Machine Manager Self-Service Portal* 

2.0 Overview  

The Microsoft System Center Virtual Machine Manager Self-Service Portal* 2.0 (VMMSSP*1) is a free, 

partner-extensible portal that enables private cloud and IT as a Service with Windows Server*, Hyper-V* and 

System Center Virtual Machine Manager*. With the portal, customers and partners can dynamically pool, 

allocate, and manage resources to offer Infrastructure as a Service (IaaS). Key benefits of the portal include: 

 Allocation of data center resources: The portal pools data center infrastructure resources, such as 

network, storage, load balancers, virtual machine templates, and domains, and makes them available to 

business units to meet their infrastructure needs. It also establishes the costs associated with reserving 

and using infrastructure resources. 

 Simplification of business unit on-boarding: The portal simplifies the process of on-boarding a new 

business unit infrastructure request. It provides a way for data center administrators to register 

business unit requirements in one centralized location. Business unit administrators can request 

resources in the organization’s infrastructure pool to host their IT services. 

 Validation and provision of infrastructure: The portal also simplifies the process for data center 

administrators to validate and provision a business unit IT administrator’s infrastructure requests. Using 

the portal, data center administrators can provision the requested resources and assign them to a 

requesting business unit IT administrator. 

 Self-service provisioning: The portal provides an end-user self-service feature for virtual machine 

provisioning. It streamlines the business unit IT user’s experience in managing virtual machines. And its 

extensibility scripts reduce the manual steps associated with provisioning virtual machine resources. 

 Partner extensibility: The toolkit includes powerful extensibility features for Independent Hardware 

Vendors (IHV), Independent Software Vendors (ISV) and System Integrators (SI). Partners can customize 

different virtual machine actions, such as create, delete, stop, start, shutdown, connect, and pause, to 

make use of the unique characteristics of their infrastructure. 

To provide these benefits, the portal includes the following components:  

 Self-service portal to enable IT consumers to request and provision infrastructure for their applications 

and services and to on-board new business unit IT departments. 

 Tested documentation.  

 Dynamic provisioning engine to rapidly provision virtualized infrastructure. 

 Guidance to help partners easily extend functionality. 

In addition to out-of-box functionality, VMMSSP* makes use of technologies such as Windows PowerShell*, 

Microsoft’s command shell for scripting and development, for extensibility purposes. The self-service portal 

provides an interface in which the default virtual machine actions can be extended; for example, scripts that 

interact with storage area networks (SANs) or load balancers that support virtual machines can be added. 

The self-service portal uses XML to represent the virtual machine actions. Each action, such as “CreateVM”, is 

composed of tasks. Each task, in turn, contains scripts and related parameters. Use the self-service portal to 

add, remove, or edit tasks. 

An action XML segment stores one complete set of actions and tasks. The self-service portal provides a 

default action XML segment; this action XML segment can be cloned in order to extend the virtual machine 

actions. In this way, multiple custom sets of virtual machine actions can be created. The data center 
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administrator can configure PowerShell* scripts to include specific “cmdlets” to be executed in response to a 

triggered virtual machine action, for example, to create a virtual machine. 

Microsoft Virtual Machine Manager Self-Service Portal* 2.0 

Components 

The Microsoft VMMSSP* solution has four principal components: 

 The console that manages the virtual machines using Microsoft VMMSSP* 2.0. 

 The datacenter administrative console using Microsoft Virtual Machine Manager* and, optionally, 

Microsoft Failover Cluster Manager*. 

 The datacenter administrative console that manages the virtual machine hosts’ power consumption 

using Microsoft System Center Essentials* (SCE*) 2010 Console in conjunction with Intel® Server 

Management Pack. The Microsoft  VMMSSP* Infrastructure, consisting of: 

– The Domain Controller (DC), which serves additionally as the DHCP and DNS server for the 

infrastructure. This may be a DC that is already deployed in the datacenter or a separate DC for the 

VMMSSP* infrastructure, as needed.  

– The Web/SQL server, which hosts the VMMSSP* user interface and the back-end databases required 

to keep all the components in sync with one another. Optional: Separate these into two distinct 

servers. 

– The iSCSI storage hosts, on which the Virtual Machine files reside. 

– The Virtual Machine (VM) Hosts, which may optionally be configured as a failover cluster. 
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The diagram below shows the servers that comprise these four components. Note that because VMM* must 

be installed on all servers except the domain controller, none of these systems may be virtualized within 

Hyper-V*. 

 

 
 

 

Figure 1: The Microsoft VMMSSP* Server Layout 

Refer to the Intel® Cloud Builders Reference Architecture: Microsoft System Center Virtual Machine 

Manager Self-Service Portal* 2.0 with Policy-Based Power Management for an example of how to 

configure a private enterprise cloud. 

  

http://www.esaa-members.com/app/webroot/recipes/40MSFT90CLOUD00000-01.pdf
http://www.esaa-members.com/app/webroot/recipes/40MSFT90CLOUD00000-01.pdf
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Systems Preparation 

To prepare systems for further configuration, perform these steps: 

1) Install Microsoft Windows Server* 2008 R2 x64 on all systems, according to local best-known methods. 

2) Once installation is complete, download and install the latest chipset drivers on all systems. 

3) Install the latest Intel network drivers on all systems.  During installation, select “Intel® PROSet for 

Windows* Device Manager” and “Advanced Network Services”. 

Figure 2: Network Driver Installation Options Dialog 

4) Activate Windows* copies with valid product keys. 

5) If static IP addressing is used, configure IP address, netmask, gateway, and DNS server information on all 

systems. If DHCP addressing is used, this step may be skipped. 
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6) (Optional) Enable “Remote Desktop” from any version on all systems. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3: Enabling Remote Desktop from any Client 

7) Configure Windows* Updates to automatically download, but prompt for installation on all systems. 

 
Figure 4: Configuring Windows Update to Download, but not Install, Updates 
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8) Check for and install all Windows* Updates on all systems (this may require one or more reboots before 

completing). 

Domain Controller Setup 

To configure a Microsoft Active Directory Domain Controller* (DC), for instance, if installing a new DC for 

VMMSSP* infrastructure, perform these steps (If using an existing DC, skip to Part 3): 

1) On the system that will become the DC, open a PowerShell* session (“Start” > “All Programs” > 

“Accessories” > “Windows PowerShell” > “Windows PowerShell”). 

2) Issue the command “dcpromo”. A dialog will display, indicating that Active Directory Domain Services are 

being installed. Wait for the process to complete. 

3) When the Active Directory Domain Services Installation Wizard is displayed, set the appropriate values 

for the installation. The following steps will work for an independent installation. Do not follow these 

steps if the DC must be integrated into an existing AD forest: 

a) Click “Next”. 

b) Click “Next” again. 

c) Select “Create a new domain in a new forest”, then click “Next”. 

d) Enter the FQDN of the new domain, then click “Next”. 

e) Select “Windows Server 2008 R2” as the “Forest Functional Level”, then click “Next”. 

f) Click “Next”. 

g) Click “Yes” at the “Do you want to continue?” prompt. 

h) Click “Next”. 

i) Enter a strong password then click “Next”. 

j) Click “Next” again to begin the promotion process. 

k) Check the “Reboot on completion” checkbox and wait for the process to complete. The system will 

reboot when complete. 

4) Log-in to the Domain Controller using the newly-created domain administrator account and its 

associated password. 

5) Create Domain Users: 

Note: The DCITAdmin account is used as administrator of the VMMSSP* 2.0 interface.  The 

VMMAppPool account is used for VMM* application pool, and the VMMService account is optionally used 

as an alternative to running the VMM Service as domain administrator or a local service account. Change 

the username to one appropriate for the installation environment, and remember to use the new 

username(s) in place of those given here throughout the remainder of this document. 

a) Navigate to “Start” > “Administrative Tools” > “Active Directory Users and Computers”. 

b) Expand the domain then click on “Users” folder in the left pane. 

c) Right-click in the empty space in the right pane, then select “New” > “User” from the context menu. 

i) Enter “DCITAdmin1” in the “First Name” and “User Logon Name” text boxes, then click “Next”. 

ii) Create a strong password for DCITAdmin1 user, enter it in the “Password:” and “Confirm 

Password:” text boxes, uncheck “User must change...”, (optional) check “Password never expires”, 

then click “Next”. 

iii) Click “Finish”. 

d) Right-click in the empty space in the right pane, and select “New” > “User ” from the context menu. 
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i) Enter “BUITAdmin1” in the “First Name” and “User Logon Name” text boxes, then click “Next”. 

ii) Create a strong password for BUITAdmin1 user, enter it in the “Password:” and “Confirm 

Password:” text boxes, uncheck “User must change...”, (optional) check “Password never expires”, 

then click “Next”. 

iii) Click “Finish”. 

e) Right-click in the empty space in the right pane, and select “New” > “User ” from the context menu. 

i) Enter “BUITAdmin2” in the “First Name” and “User Logon Name” text boxes, then click “Next”. 

ii) Create a strong password for BUITAdmin2 user, enter it in the “Password:” and “Confirm 

Password:” text boxes, uncheck “User must change...”, (optional) check “Password never expires”, 

then click “Next”. 

iii) Click “Finish”. 

f) Right-click in the empty space in the right pane, and select “New” > “User ” from the context menu. 

i) Enter “VMMAppPool” in the “First Name” and “User Logon Name” text boxes, then click “Next”. 

ii) Create a strong password for VMMAppPool user, enter it in the “Password:” and “Confirm 

Password:” text boxes, uncheck “User must change...”, (optional) check “Password never expires”, 

then click “Next”. 

iii) Click “Finish”. 

g) Right-click in the empty space in the right pane, and select “New → User” from the context menu. 

i) Enter “VMMService” in the “First Name” and “User Logon Name” text boxes, then click “Next”. 

ii) Create a strong password for VMMService user, enter it in the “Password:” and “Confirm 

Password:” text boxes, uncheck “User must change...”, (optional) check “Password never expires”, 

then click “Next”. 

iii) Click “Finish”. 

h) Add two of the new users to the “Domain Admins” group. Right-click “DCITAdmin1”, then select “Add 

to a group…” from the context menu. 

i) Type “Domain Admins”. 

ii) Click “OK”. 

iii) Click “OK”. 

i) Right-click “VMMAppPool”, then select “Add to a group…” from the context menu. 

i) Type “Domain Admins”. 

ii) Click “OK”. 

iii) Click “OK”. 

6) Log-in to each system and join it to the newly-created domain. 
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Web/SQL Server Setup (Phase 1) 

To configure the Web and SQL server, perform these steps on the server that will fulfill these two roles: 

1) Log-in to the system as a user with domain administrator privileges. 

2) Install Internet Information Server* (IIS*): 

a) At the Initial Configuration Tasks screen, select “Add roles” under “Customize This Server”.  

b) Click “Next”. 

c) Check “Application Server”. 

d) At the pop-up dialog, click “Add Required Features”.  

e) Check “File Services”, “Hyper-V”, and “Web Server (IIS)”, then click “Next”. 

f) Click “Next”, then click “Next” in the two screens that follow. 

g) Scroll down to check “Windows Authentication” and “IIS 6 Metabase Compatibility”, then click “Next”. 

h) Click “Next”, then click “Next” in the two screens that follow. 

i) Select a network adapter for Hyper-V* networking from the list of adapters, then click “Next”. 

j) Click “Install”. 

k) Click “Close”. 

l) Click “Yes”. The system will reboot. 

m) Once the system reboots, log back in as the same user, and wait for the installation to complete. 

n) When the installation completes, click “Close”. 

3) Install SQL Server* 2008 R2. 

Note:  SQL Server* 2008 R2 may be installed on a separate server. If an SQL Server 2008 R2 server is 

already in the network, it may be used instead of installing a redundant copy. These instructions provide 

for a basic SQL Server 2008 R2 installation. If there is a local BKM for installation, that may be used 

instead. 

a) Launch Setup.exe. 

b) Click “Installation” in the left column. 

c) Click “New installation or add features to an existing installation” in the right column. 

d) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

e) Click “OK”. 

f) Enter the product key, then click “Next”. 

g) Read the Microsoft* Software License Terms, check the “I accept the license terms” checkbox, 

(optional) check the “Send feature usage...” checkbox, then click “Next”. 

h) Click “Install”. 

i) If this results in 0 failures, 1 warning (Windows Firewall), continue. If there are any failures or other 

warnings, correct them before continuing. 

j) Click “Next”, then click “Next” again. 
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k) Select the following items by checking the appropriate checkboxes: 

– Database Engine Services 

– SQL Server Replication 

– Full-Text Search 

– Analysis Services 

– Reporting Services 

– Client Tools Connectivity 

– SQL Server Books Online 

– Management Tools – Basic 

– Management Tools – Complete 

– SQL Client Connectivity SDK 

l) Click “Next”. 

m) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

n) Click “Next”, then click “Next” in the two screens that follow. 

o) If there are no user accounts for SQL services, the following settings will work, but are not as 

secure: 

− SQL Server* Agent and SQL Server Database Engine: NT AUTHORITY\SYSTEM 

− SQL Server* Analysis Services and SQL Server Reporting Services: NT AUTHORITY\LOCAL 

SERVICE 

p) Click “Next”. 

q) Click “Add Current User” if you want the domain administrator to have administrator privileges on 

the SQL database.  Otherwise, click “Add...” and select users to be added. 

r) If SQL users are not required, click “Next”.  If SQL users are required, select the “Mixed Mode...” radio 

button, enter and confirm the “sa” password, then click “Next”. 

s) Click “Add Current User” to provide domain administrator with administrator privileges for Analysis 

Services.  Otherwise, click “Add...”, then select users to be added. 

t) Click “Next”, then click “Next” in the two screens that follow. 

u) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

v) Click “Next”. 

w) Click “Install”. 

x) “Your SQL Server 2008 R2 installation completed successfully.” will display if the installation is 

successful. If so, click “Close”. Otherwise, resolve the errors and retry. 

y) Close the SQL installation window. 

4) Configure Windows* Firewall to allow SQL data through: 

a) Open Windows* Firewall (“Start” > “Administrative Tools” > “Windows Firewall with Advanced 

Security”). 

b) Click “Inbound Rules” in the left pane. 

c) Right-click “Inbound Rules” in the left pane, then select “New Rule…” from the context menu. 

d) Click “Next”. 

e) Click “Browse...”, then browse to “C:\Program Files\Microsoft SQL Server\MSSQL10_50. 

MSSQLSERVER\MSSQL\Binn” 
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f) Double-click “sqlservr”. 

g) Click “Next”, then click “Next” in the two screens that follow. 

h) Enter “SQL Server” in the “Name” text box, then click “Finish”. 

i) Right-click “Inbound Rules”, then select  “New Rule...” from the context menu. 

j) Select the “Port” radio button, then click “Next”. 

k) Select the “UDP” radio button, enter “1434” in the “Specific local ports:” text box, then click “Next”. 

l) Click “Next”. 

m) Click “Next”. 

n) Enter “SQL-1434” in the “Name:” text box, then click “Finish”. 

o) Close the Windows Firewall with Advanced Security window. 

5) Check for and apply any updates 

a) Navigate to “Start” > “All Programs” > “Windows Update”. 

b) Click “Check for updates” in the left pane. 

c) Click “Install Updates”. 

d) Restart, if necessary. 

Note: Web/SQL Server Setup (Phase 2) is described on page 22 

VMM* Console Setup 

To configure VMM*, perform these steps on the system that will fulfill the role of VMM Console: 

1) Log-in with an account which has domain administrator privileges. 

2) Install required roles: 

a) In the Initial Configuration Tasks screen, select “Add roles” under “Customize This Server”. 

b) Click “Next”. 

c) Check “Application Server”. 

d) In the pop-up dialog, click “Add Required Features”. 

e) Check “File Services” and “Hyper-V”, then click “Next”. 

f) Click “Next”, then click “Next” in the four screens that follow. 

g) Select network adapter for Hyper-V* networking, then click “Next”. 

h) Click “Install”. 

i) Click “Close”. 

j) Click “Yes”.  The system will reboot. 

k) Log-in. 

l) Wait for installation to finish, then click “Close”. 

3) Open Server Manager. If it isn't already on-screen, navigate to “Start” > “Administrative Tools” > “Server 

Manager”. 

4) Click “Features” in the left pane. 

5) Click “Add Features” in the right pane: 

a) Check “Background Intelligent Transfer Service (BITS)”. 

b) In the pop-up dialog, click “Add Required Role Services”.  

c) Check “Failover Clustering”. 

d) Expand “Message Queuing” > “Message Queuing Services”, then check “Directory Service 

Integration”. 
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e) In the pop-up dialog, click “Add Required Features”.  

f) Click “Next”. 

g) Click “Next”. 

h) Verify that “Management Tools” > “IIS 6 Management Compatibility” > “IIS 6 Metabase 

Compatibility” is checked, then click “Next”. 

i) Click “Install”. 

j) When installation is complete, click “Close”. 

6) Install Microsoft SQL* 2008 R2 Client Connectivity tools: 

a) Run setup.exe. 

b) Click “Installation” in the left column. 

c) Click “New installation or add features to an existing installation” in the right column. 

d) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

e) Click “OK”. 

f) Enter the product key, then click “Next”. 

g) Read the Microsoft* Software License Terms, check the “I accept the license terms” checkbox, 

(optional) check the “Send feature usage...” checkbox, then click “Next”. 

h) Click “Install”. 

i) If this results in 0 failures, 1 warning (Windows* Firewall), continue. If there are any failures or other 

warnings, correct them before continuing. 

j) Click “Next”, then click “Next” again. 

k) Select the following items by checking the appropriate checkboxes: 

– Client Tools Connectivity 

– SQL Server Books Online 

– Management Tools – Basic 

– Management Tools – Complete 

– SQL Client Connectivity SDK 

l) Click “Next”. 

m) If this results in 0 failures, 0 warnings, continue.  If there are any failures or warnings, correct them 

before continuing. 

n) Click “Next”, then click “Next” in the two screens that follow. 

o) If this results in 0 failures, 0 warnings, continue.  If there are any failures or warnings, correct them 

before continuing. 

p) Click “Next”. 

q) Click “Install”. 

r) “Your SQL Server 2008 R2 installation completed successfully.” will display if the installation is 

successful. If so, click “Close”.  Otherwise, resolve the errors and retry. 

s) Close the SQL installation window. 

7) Prepare the Windows* Firewall for VMM* Administration Console: 

a) Open Windows* Firewall; navigate to “Start” > “Administrative Tools” > “Windows Firewall with 

Advanced Security”. 

b) Left-click “Inbound Rules” in the left pane. 

c) Right-click “Inbound Rules” in the left pane, then select “New Rule...”. 
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d) Select the “Port” radio button, then click “Next” 

e) Enter 8100 in the “Specific local ports” text box, then click “Next”. 

f) Click “Next”. 

g) Click “Next”. 

h) Enter “VMM Admin Console” (without the quotes) in the “Name:” text box, then click “Finish”. 

i) Close the Windows Firewall Advanced Settings window. 

8) Install Virtual Machine Manager* 2008 R2 Server. (mu_system_center_virtual_machine_manager_ 

2008_r2_x64_dvd_x15-83150 DVD ISO from MSDN) 

Note: Do not try to launch System Center Virtual Machine Manager* Console until completing the 

VMMSSP* website component on the Web/SQL server  

a) Run setup.exe. 

b) Click “VMM Server”. 

c) Read the Microsoft* Software License Terms, select the “I accept the license terms” radio button, 

then click “Next”. 

d) Select the “Use Microsoft Update...” radio button, then click “Next”. 

e) Select the radio button that matches the willingness to participate in the “Customer Experience 

Improvement Program”, then click “Next”. 

f) Enter the User Name and Company for this installation, then click “Next”. 

g) Click “Next”. 

h) Click “Next”. 

i) Enter the name of the Web/SQL server in the “Server name:” text box. 

j) Select the SQL instance from the “Select or enter a SQL instance” dropdown box, likely 

“MSSQLSERVER”. 

k) Check the “Create a new database” checkbox, then click “Next”. 

l) Click “Next”. 

m) Click “Next”. 

n) Click “Install”. 

o) When installation completes, uncheck “Check for the latest...”, then click “Close”. 

9) Install Virtual Machine Manager* 2008 R2 Administrator Console 

a) Click “VMM Administrator Console”, located below “Setup” in the right-hand column. 

b) Read the Microsoft* Software License Terms, select the “I accept the license terms” radio button, 

then click “Next”. 

c) Click “Next”, then click “Next” in the three screens that follow. 

d) Click “Install”. 

e) When installation completes, uncheck “Check for the latest...”, then click “Close”. 

f) Click “Exit” in the lower right corner of the window. 

10) Install Virtual Machine Self-Service Portal Server* (file “SetupVMMSSP.exe” from Microsoft* at 

http://tinyurl.com/29zg552) 

a) Run SetupVMMSSP.exe. 

b) Click ”Install”. 

c) Read the Microsoft* Software License Terms, check the “I have read, understood and agree to these 

license terms” checkbox, then click “Next”. 

d) Check the “VMMSSP server component” checkbox, then click “Next”. 

http://tinyurl.com/29zg552
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Note: If the prerequisites check fails due to “The directory service integration feature of Message 

Queuing is not installed”, cancel the setup and take the following steps prior to retrying setup: 

a) Uninstall ALL message queuing features from “Server Manager” > “Features” > “Remove Features”. 

This will require a reboot to complete. 

b) After receiving the success message, reinstall “Message Queuing Server” and “Directory Service 

Integration”. 

c) Check that it resolved the problem by examining (DO NOT CHANGE) registry key at: 

HKLM\Software|Microsoft\MSMQ\Parameters\Workgroup. This should be 0. If it is 1 after 

reinstallation, follow workaround instructions at Microsoft TechNet forums at this link: 

http://tinyurl.com/6kt5d5k, the message from Yogesh C dated Monday, February 14, 2011 4:28pm. 

a) Click “Next”. 

b) Click “Next”. 

c) Enter the Web/SQL server name in the “Database server:” text box, then click “Get Instances...”. 

d) Once “SQL Server instance” is populated with “Default”, click “Next”. 

e) Enter the domain administrator's password in the “Password” text box, then click “Test account”. 

f) If “The user name or password is incorrect” is displayed, correct the user name and/or password, 

then click “Test account” again. 

g) Click “Next”. 

h) Click “Next”. 

i) Replace “DOMAIN” with the unique domain name in the following step. 

j) Enter “DOMAIN\Administrator, DOMAIN\DCITAdmin1” in the text box, then click “Next”. 

k) Click “Install”. 

l) Click “Yes”. 

m) When installation completes, click “Close”. 

11) Check for and apply any updates: 

a) Navigate to “Start” > “All Programs” > “Windows Update”. 

b) Click “Check for updates” in the left pane. 

c) Click “Install Updates”. 

d) Restart, if necessary. 

  

http://tinyurl.com/6kt5d5k
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Web/SQL Server Setup (Phase 2) 

To configure the Web server side of VMMSSP* 2.0, perform these steps: 

1) Install Virtual Machine Self-Service Portal* (file SetupVMMSSP.exe from Microsoft* at 

http://tinyurl.com/29zg552) 

a) Run SetupVMMSSP.exe. 

b) Click “Install”. 

c) Read the Microsoft Software License Terms, check the “I have read, understood and agree to these 

license terms” checkbox, then click “Next”. 

d) Check the “VMMSSP website component” checkbox, then click “Next”. 

e) Click “Next”. 

f) Click “Next”. 

g) In the “User Name:” text box, enter “VMMAppPool”, enter that account's password in the “Password:” 

text box, enter the domain name in the “Domain:” text box, then click “Next”. 

h) In the “Database server:” text box, enter the name of the SQL server, then click “Get Instances...”. 

i) Once “SQL Server instance” is populated with “Default”, click “Next”. 

j) Enter the name of the Management Console/Server in the “Server name:” text box, then click “Next”. 

k) Click “Install”. 

l) Click “Close”. 

2) Check for and apply any updates: 

a) Navigate to “Start” > “All Programs” > “Windows Update”. 

b) Click “Install Updates”. 

c) Restart, if necessary. 

Configure Storage Server(s) 

Create iSCSI Target(s) on the Storage Server(s) 

Detailed instructions for creating iSCSI targets are out of scope of this document. 

VMM* Host Configuration 

To configure the Virtual Machine Manager* (VMM*) host servers, perform these steps on each host: 

1) Use iSCSI Initiator to map to iSCSI storage: 

a) Open iSCSI Initiator (“Start” > “Administrative Tools” > “iSCSI Initiator”). 

b) In the Microsoft iSCSI dialog, click “Yes”. 

c) For each iSCSI target, enter the IP address of the iSCSI target in the “Target” field, then click “Quick 

Connect…”. 

d) Click “Done”. 

e) Click “OK”. 

2) Install Sanbolic* Melio FS* 

 Note: be sure to have Melio* licenses from Sanbolic for all Hyper-V* nodes before continuing. 

http://tinyurl.com/29zg552
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a) Launch Melio FS* Setup 3.1.42.21386 (or later). 

b) Read the License Agreement, select the “I accept the agreement” radio button, then click “Next”. 

c) Select “This is a new installation…”, then click “Next”. 

d) Click “Next”, then click “Next” in the two screens that follow. 

e) Select the network over which Melio FS* will communicate (descending order of preference): 

– Dedicated 10GbE connection 

– Shared 10GbE connection  

– Dedicated 1GbE connection 

– Shared 1GbE connection  

then click “Next”. 

f) Click “Next”. 

g) Enter an account with local administrator privileges in the “Machine Account name:” text box, the 

associated password in the “Password:” text box, and then click “Next”. 

h) If SILM was selected for installation continue with this step.  Otherwise, continue with the following 

step.  Again, enter an account with local administrator privileges in the “Machine Account name:” 

text box, the associated password in the “Password:” text box, and then click “Next”. 

i) Click “Install”. 

j) At the Would you like to install this device software? dialog, check the checkbox next to “Always 

trust software from “Sanbolic, Inc.”.”, then click “Install”. 

k) Select the “Full Version” radio button, then click “Next”. 

l) Enter the username, company, and registration key provided by Sanbolic (remember to type the 

dashes [ - ]. Omitting them will result in an invalid key error), then click “Next”. 

m) Click “Finish”. 

3) Configure Firewall for Melio FS*: 

a) Open Windows Firewall configuration (“Start” > “Administrative Tools” > “Windows Firewall with 

Advanced Security”. 

b) Select “Inbound Rules” from the left pane. 

c) Verify that Melio FS* TCP, Melio FS UDP, LaScala Volume Manager* TCP, and LaScala Volume 

Manager UDP are all configured for the network selected during setup of Melio FS. 

d) Close Windows Firewall with Advanced Security. 

4) Configure Shared Storage: 

a) On the first Hyper-V* Node only: 

i) Launch LaScala* volume manager (“Start” > “All Programs” > “Sanbolic” > “LaScala Volume 

Manager”. 

ii) Expand the left pane until the computer name is displayed. Left click the computer name. If the 

computer name is not displayed after expanding the entire tree, select “View” > “Select 

Managed Computers…” to add the computer to LaScala*. 

iii) Right-click the first disk marked “Empty”.   

b) If there are multiple disks, select “Manage Multiple…”: 

i) Verify all disks are checked at the top of the dialog, then check “Automatically create…” and “And 

stripe them”. 

ii) Click “OK”. 
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c) If there is only one disk, select “Manage …”: 

i) Verify the disk is checked at the top of the dialog, then check “Automatically create…”, then click 

“OK”. 

ii) Click “Yes”, then wait for the formatting/striping process to finish. 

iii) At the Enter Stripe Size dialog, select the desired stripe size (the default, 64 KB, is usually 

sufficient), then click “OK”. 

iv) Select “Action” > “Apply Changes…”. 

v) Click “Yes” at the confirmation dialog. 

vi) Click “OK” at the status window, if everything is successful. If there are errors, debug and resolve 

them before continuing. 

vii) Right click “Stripe Set” in the upper middle pane, then click “Create Logical Drive…”. 

viii) Select a drive letter for the shared storage. Try to select a letter that is available on all Hyper-V* 

Compute Nodes. Enter a volume label if desired, then click “OK”. 

ix) Once processing is completed, click “OK”. 

x) If Windows* prompts for a restart, click “Restart Later”. 

xi) Close LaScala*. 

d) On the remaining Hyper-V* Nodes: 

i) Verify that the drive is properly displayed in “Computer”.  

ii) If it is not, recheck the Windows* Firewall rules, and open LaScala* volume manager.  

iii) If LaScala leaves the disk(s) stuck in “Initializing…”, it is likely due to network or firewall 

misconfiguration. 

5) Add Hyper-V*: 

a) In the Initial Configuration Tasks screen, select “Add roles” under “Customize This Server”. 

b) Click “Next”. 

c) Check “Hyper-V”, then click “Next”. 

d) Select network adapter for Hyper-V* networking, then click “Next”. 

e) Click “Install”. 

f) Click “Close”. 

g) Click “Yes”. The system will reboot. 

h) Log-in. 

i) Wait for installation to finish, then click “Close”. 

6) Add Failover Clustering: 

a) In the Initial Configuration Tasks screen, select “Add Features” under “Customize This Server”.  

b) Click “Next”. 

c) Check “Failover Clustering”, then click “Next”. 

d) Click “Install”. 

e) Wait for installation to finish, then click “Close”. 

7) Check for and apply any updates: 

a) Navigate to “Start” > “All Programs” > “Windows Update”. 

b) Click “Check for updates” in the left column. 

c) Click “Install Updates”. 

d) Restart, if necessary. 
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Create VM Template 

To create a VM Template, perform these steps: 

1) On only one VM host, create a virtual machine: 

a) Navigate to “Start” > “Administrative Tools” > “Hyper-V Manager”. 

b) Select the node name in the left pane. 

c) Click “New” > “Virtual Machine” from the right pane. 

d) Click “Next”. 

e) Enter a name in the “Name:” text box (e.g., “Win2008r2”), check “Store the virtual machine in a 

different location”, click “Browse…”, navigate to the shared storage drive, click “Select Folder”, then 

click “Next”. 

f) Select “Processor” from the “Hardware Profile” column, select “4” from the “Number of CPUs” drop-

down box, then select “3.40 GHz Pentium D (dual core)” from the “CPU Type” drop-down box. 

g) Select “Memory” from the “Hardware Profile” column, enter 4096 in the “Memory:” text box, then 

click “Next”. 

h) Select the network connection from the dropdown list, then click “Next”. 

i) Change the “Size” text box value from “127” to “40”, then click “Next”. 

j) Select the “Install an operating system from a boot CD/DVD-ROM” radio button, select the drive or 

ISO that contains the OS to install, then click “Next”. 

k) Install the OS on the virtual machine: 

i) Double-click the new virtual machine from the middle pane. 

ii) Select “Action” > “Start” from the menu bar. 

iii) Complete standard OS installation. 

iv) After installation is complete, apply all security patches, then power off the virtual machine. 

2) On the Management console/server: 

a) Run SCVMM Admin Console (shortcut on the desktop). 

b) Click “Add host” in the right pane. 

c) Enter username, password, and domain name in the provided text boxes, then click “Next”. 

d) Click “Search...”. 

e) In the “Computer name:” text box, enter enough of the compute node system names to match them 

all, then click “Search”. 

f) Click the first compute node in the list. Scroll to the bottom of the list, hold down the shift key, and 

click the last compute node in the list. Release the shift key, then click “Add”. 

g) Click “OK”. 

h) Click “Next”. 

i) At the One or more of the servers… dialog, click “Yes”.  

j) Click “Next”. 

k) Enter the Shared Storage drive letter and path, then click “Add”. 

l) Click “Next”. 

m) Click “Add Hosts”. 

n) When all hosts are successfully added, close the Jobs window. 

o) Create a template based on the installed VM: 

i) Click “Virtual Machines” in the lower portion of the left pane. 
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ii) Right-click the virtual machine name in the upper middle pane, then select “New template” from 

the context menu. 

iii) Click “Yes”. 

iv) Enter a name in the “Template name:” text box, and a description in the “Description:” text box, 

then click “Next”. 

v) Click “Next”. 

vi) Select the OS installed on the VM from the “Operating system:” drop-down box, then click 

“Next”. 

vii) Click “Next”. 

viii) Click “Browse...”, expand “MSSCVMMLibrary”, select “VHDs”, then click “OK”. 

ix) Click “Next”. 

x) Click “Create”. 

xi) If there are no errors when the job completes, close the Jobs window. 

Install Power Management Tools 

To install the power management tools, perform these steps: 

1) On each system that will be power managed, install Intel Client Agent files (AgentDriver_x86.exe [32-

bit] or AgentDriver_x64.exe [64-bit] from intel.com at http://tinyurl.com/47racwg) 

a) Run AgentDriver_xXX.exe. 

b) Click “Next”. 

c) Read the Intel License Agreement, select the “I accept…” radio button, then click “Next”. 

d) Click “Install”. 

e) Click “Finish”. 

2) Verify BMC network is configured in BIOS setup: 

a) Reboot; enter BIOS Setup. 

b) Select “Server Management”. 

c) Select “BMC Configuration”. 

d) Configure IP information as appropriate to the server’s network. 

Install and Configure Microsoft System Center Essentials* 

(SCE*) 2010 Console 

To install and configure Microsoft SCE* 2010 Console, perform these steps on the server identified as the 

SCE server: 

1) Install IIS* and .NET*: 

a) Open Server Manager. 

b) Click “Roles” in the left pane. 

c) Click “Add Roles” in the right pane. 

d) Click “Next”. 

e) Check “Web Server (IIS)”, then click “Next”. 

f) Click “Next”. 

http://tinyurl.com/47racwg
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g) Check “ASP.NET”, then click “Add Required Role Services”. 

h) Click “Next”. 

i) Click “Install”. 

j) Click “Close”. 

2) Install .Net 3.5.1 

a) Open Server Manager (if it was closed). 

b) Click “Features” in the left pane. 

c) Click “Add features” in the right pane. 

d) Click “Next”. 

e) Check “.Net Framework 3.5.1 Features (Installed)” (should have a gray-filled checkbox when 

starting), then click “Add Required Features”. 

f) Click “Next”. 

g) Click “Install”. 

h) Click “Close”. 

3) Install Microsoft SQL* 2008 R2 Client Connectivity tools: 

a) Run setup.exe. 

b) Click “Installation” in the left column. 

c) Click “New installation or add features to an existing installation” in the right column. 

d) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

e) Click “OK”. 

f) Enter the product key, then click “Next”. 

g) Read the Microsoft* Software License Terms, check the “I accept the license terms” checkbox, 

(optional) check the “Send feature usage...” checkbox, then click “Next”. 

h) Click “Install”. 

i) If this results in 0 failures, 1 warning (Windows* Firewall), continue. If there are any failures or other 

warnings, correct them before continuing. 

j) Click “Next”. 

k) Click “Next”. 

 

l) Select the following items by checking the appropriate checkboxes: 

– Client Tools Connectivity 

– SQL Server Books Online 

– Management Tools – Basic 

– Management Tools – Complete 

– SQL Client Connectivity SDK 

m) Click “Next” 

n) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 

o) Click “Next”, then click “Next” in the two screens that follow. 

p) If this results in 0 failures, 0 warnings, continue. If there are any failures or warnings, correct them 

before continuing. 
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q) Click “Next”. 

r) Click “Install”. 

s) This should result in “Your SQL Server 2008 R2 installation completed successfully.” If so, click 

“Close”.  Otherwise, resolve the errors and retry. 

t) Close the SQL installation window. 

4) Install Microsoft System Center Essentials* (SCE*) 2010 

(en_system_center_essentials_2010_x86_x64_dvd_516332.iso DVD ISO from MSDN)   

a) Run SetupSCE.exe. 

b) Click “Install”. 

c) Enter User and Organization names in the appropriate text boxes (“Name:” and “Organization:”), and 

the Product Key, then click “Next”. 

d) Read the Microsoft* Software License Terms, check the “I accept the license terms” check box, then 

click “Next”. 

e) If reporting is required, review the requirements for reporting, resolve them, and click “Next”. 

Otherwise, uncheck “Reporting”. In either case, uncheck “Virtualization Management”, then click 

“Next”. 

f) Resolve any warnings (other than the “WSUS valid date” warning, which may be safely ignored), 

then click “Check again…”. 

g) Click “Next”. 

h) Select “Specify a remote instance of SQL Server 2008 SP1 later, in Setup.”, then click “Next”. 

i) Click “Select a Server”. 

j) Enter the name of the Web/SQL server in the “Enter the object name to select (examples):” text box, 

then click “OK”. 

k) Verify that the server is selected, then click “Next”. 

l) Decide whether managed systems should receive Microsoft* updates from the SCE* server or 

directly from Microsoft. Select the appropriate radio button, then click “Next”. 

m) Click “Next”. 

n) Enter domain admin username and password in the appropriate text boxes, then click “Test”. 

o) Click “Next”. 

p) Decide whether to participate in the Customer Experience Improvement Program and Error 

Reporting Programs, select the appropriate radio buttons, check the “Use Microsoft Update to 

receive updates…”, then click “Next”. 

q) Click “Install”. 

r) When installation completes, uncheck “Open the System Center Essentials...”, then click “Close”. 

5) Install Intel® Server Management Pack 3.6.x (SMS36-FullSetup.exe, from intel.com at 

http://tinyurl.com/4eozxa6): 

a) Run SMS36-FullSetup.exe. 

b) Select language, then click “OK”. 

c) Click “Next”. 

d) Read the Intel License Agreement, select the “I accept…” radio button, then click “Next”. 

e) Enter the username and password of a domain admin, then click “Next”. 

f) Click “Install”. 

g) Click “Finish”. 

h) Click “Yes”. The server will reboot. 

http://tinyurl.com/4eozxa6
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6) Install Intel Client Agent files (AgentDriver_x86.exe or AgentDriver_x64.exe from intel.com at 

http://tinyurl.com/47racwg): 

a) Run AgentDriver_xXX.exe. 

b) Click “Next”. 

c) Read the Intel License Agreement, select the “I accept…” radio button, then click “Next”. 

d) Click “Install”. 

e) Click “Finish”. 

7) Set-up the SCE* Console: 

a) Run System Center Essentials Console (“Start” > “All Programs” > “System Center Essentials 2010” 

> “System Center Essentials Console”. 

b) Click “Start”. 

c) Select the radio button that matches whether local or domain Group Policies are used in the domain, 

then click “Next”. 

d) Click “Next”. 

e) Select “No”, then click “Next”. 

f) If email notifications are to be used, enter the appropriate information (To: and From: addresses, 

SMTP Server, port and authentication method, and daily health report schedule) in the boxes. 

Otherwise, select “No”. After appropriate selections are made, click “Next”. 

g) If a proxy server is used to connect to the internet, select “Yes”, and enter the proxy information. If 

no proxy server is used or after the proxy server information is entered, click “Synchronize”. 

h) Click “Next”. 

i) Enter a directory for storage of errors in the “Error reporting upload location…” text box, then click 

“Next”.  

j) Determine whether errors should be automatically forwarded to Microsoft. If they should, check the 

“Automatically forward…” checkbox. Either way, then click “Next”. 

k) Click “Next”, then click “Next” in the two screens that follow. 

l) If patches are to be forced to domain computers, select “Force installation after a specified interval”, 

set the delay in days, and the time for installation. Once this is set or left unset, based on the 

requirements of the domain, click “Next”. 

m) Click “Configure”. 

n) Check “Synchronize updates when this wizard closes”, then click “Close”. 

o) Click “Next”. 

p) Click “Next”. 

q) Click “Discover”. 

r) Select the systems to be power-managed, then click “Next”. 

s) Click “Finish”. 

8) Configure Power Management monitoring: 

a) In the bottom of the left pane, click “Monitoring”. 

b) In the top of the left pane, expand “Intel Agentless Servers (OOB)”, then select “Configuration”. 

c) In the right pane, click “Intel® Server:Discovery…”. 

d) Under the “Server Groups” heading, click “New”. 

e) Enter a name in the “Group Name” text box, then click “Create”. 

http://tinyurl.com/47racwg
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f) Under the “BMC IP Address Range” heading, enter “From” and “To” IP Addresses that encompass all 

of the configured BMC IP Addresses, then click “Add”. 

g) Click “Discover”. 

h) For each “Discovered Server”: 

i) Click in the “IPMI User” field, then enter the name of the user that was configured during BMC 

setup. 

ii) Click in the “Server Name” field, then enter the server name. 

iii) Check the “Enable Monitoring” checkbox. 

i) Enter the BMC password in the “password” text box, then click “Update”. 

j) Click “Save”. 

k) Click the Power Monitoring tab. 

l) Click “New”. 

m) Enter a new group name for the power monitoring group, then click “Create”. 

n) Click “Save”. 

o) Click “Exit”. 

p) Wait approximately 3-5 minutes for power supply type to register. 

q) In the right pane, click “Intel® Server:Discovery…”. 

r) Click the Power Monitoring tab. 

s) Select all systems in the “Discovered Servers” list that list Power Supply as “PMBus”, then click the 

“>>” button to add them to the power monitoring group. 

t) Click “Save”. 

u) Click “Exit”. 

Create and Distribute Power Management Policy/Policies 

To create and distribute power management policies to the servers, perform these steps on the server 

identified as the SCE* server: 

1) Open SCE* Console (if it isn’t still open). 

2) Select “Monitoring” from the lower section of the left pane. 

3) Select “Intel Agentless Servers (OOB)” > “Power Monitoring” > “Individual Consumption(Watts)” from the 

upper section of the left pane. 

4) Select one of the systems to be power managed from the lower section of the middle pane. 

5) Click “Intel Server: Intel® Active System Console” (IASC) from the lower section of the right pane. 

6) Enter a username/password combination that has domain administrator privileges, then click “OK”. 

7) Click “BMC Configuration” in the lower left corner of the IASC window. 

8) Click “Node Manager” from the tree list in the upper section of the left pane. 

9) Read the warning in the right pane, then click “Continue”. 

10) Create one or more power management policies: 

a) Check the “Enable Node Manager Policies” checkbox. 

b) Click “Add” under the “Policies” heading. 

c) Select “Enable” next to “Policy Active”. 

d) Enter the power limit in watts in the “Power Limit (Watts)” text box (e.g., for S5520UR server, enter 

“275”). 
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e) Select “Start Time” and “End Time” from the appropriate drop-down boxes. Note that this tool does 

not allow a policy to cross over to Midnight, so if an overnight policy is desired, two policies must be 

created – one that begins at the desired time and ends at 11:54 pm, and a second that begins at 

midnight and ends at the desired time. 

f) Select recurrence as either “All Days” or “Selected Day”. If “Selected Day” is selected, choose the day 

from the drop-down box. 

g) Check the “Send Alert” checkbox (policy will not save properly if this box is not checked). 

h) Click “Apply”. 

i) If additional policies are required, repeat these steps for each additional policy. 

11) Export policy/policies to local drive for distribution to all nodes. For each policy that is desired on multiple 

servers, take the following steps to export the policy: 

a) Select the radio button next to the policy. 

b) Click “Export to File” below “Policies”. 

c) Select the option to save the file (e.g., in Internet Explorer*, click “Save”). 

d) Provide a descriptive name (e.g., “Policy-WATTS-STARTTIME-ENDTIME”, where “WATTS”, 

“STARTTIME”, and “ENDTIME” are replaced by the power limit watts, start time, and end time of the 

policy, respectively), then click “Save”. 

e) Close the IASC window. 

12) Distribute policy/policies to all applicable servers. In the SCE Console window: 

a) Select “Monitoring” from the lower section of the left pane. 

b) Select “Intel Agentless Servers (OOB)” > “Power Monitoring” > “Individual Consumption(Watts)” from 

the upper section of the left pane. 

c) Select one of the systems to be power-managed from the lower section of the middle pane. 

d) Click “Intel Server: Update Password for Agentless Management” from the lower section of the right 

pane. 

e) Click the Power Monitoring tab. 

f) For each policy that is desired on multiple servers: 

i) If there are multiple power groups, select the power group the policy/policies will be applied to. 

ii) Click the “Import” button in the “Power Group Operations” grouping. 

iii) Click the “…” button to open the file selection dialog window. 

iv) Navigate to the directory in which the policy/policies are stored. Select the policy to be applied, 

then click “Open”. 

v) Click “Apply”. 

vi) Wait for the “Status” column to change to “Applied” for each server in the group. 

g) Once all desired policies are applied, click “Exit” to close the Import dialog window. 

h) Click “Exit” to close the Discovery Wizard. 

i) For each server that had one or more policies applied in the preceding steps, take the following 

steps to enable the policies  

Note: Policies are disabled when distributed to nodes. Failure to take these steps will result in disabled 

policies on the servers. 

i) Select the server from the bottom of the middle pane. 

ii) Click “Intel Server: Intel® Active System Console” from the lower section of the right pane. 
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iii) Enter a username/password combination that has domain administrator privileges, then click 

“OK”. 

iv) Click “BMC Configuration” in the lower left corner of the IASC window. 

v) Click “Node Manager” from the tree list in the upper section of the left pane. 

vi) Read the warning in the right pane, then click “Continue”. 

vii) For each policy to be enabled, select the radio button to the left of the policy. 

viii) Click “Enable” below “Policies”. 

ix) Close the IASC window. 

13) Monitor power levels: In the lower section of the middle pane, check the checkbox next to each server 

that is to be monitored in the graph in the upper section of the middle pane.  Updates occur 

approximately every thirty minutes, so information may not be displayed immediately upon selection. 

Create Failover Cluster Configuration 

To create a failover cluster configuration for the VMs, perform these steps: 

1) Stop all virtual machines on all hosts. 

2) On the Virtual Machine Manager console, launch Failover Cluster Manager (“Start” > “Administrative 

Tools” > “Failover Cluster Manager”). 

3) Validate the servers are configured in a manner acceptable for clustering: 

a) Click “Validate a Configuration…” in the middle of the center pane. 

b) Click “Next”. 

c) Click “Browse…”. 

d) Click “Advanced…”. 

e) Enter enough of the server names to return all of them in the “Name” text box, then click “Find 

Now”. 

f) Select all Hyper-V* hosts, then click “OK”. 

g) Click “OK”. 

h) Click “Next”. 

i) Click “OK”. 

j) Click “Next”. 

k) Verify there are no errors, and that any warnings are understood before continuing. 

l) Click “Finish”. 

4) Create a Cluster: 

a) Click “Create a Cluster…” in the middle of the center pane. 

b) Click “Next”. 

c) Click “Browse…”. 

d) Click “Advanced…”. 

e) Enter enough of the server names to return all of them in the “Name” text box, then click “Find 

Now”. 

f) Select all Hyper-V* hosts, then click “OK”. 

g) Click “OK”. 

h) Click “Next”. 
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i) Enter a name for the cluster in the “Cluster Name” text box, and an unused IP address in the IP 

Address text box, then click “Next”. 

j) Click “Next”. 

k) Click “Finish”. 

5) Configure VMs for High Availability: 

a) Click “Services and Applications” in the left pane. 

b) Click “Configure a Service or Application” in the right pane. 

c) Click “Next”. 

d) Select “Virtual Machine”, then click “Next”. 

e) Select all the Virtual Machines that should be highly available, then click “Next”. 

f) Click “Next”. 

g) If there are any warnings or errors click “View Report” to review them before continuing. 

h) Click “Finish”. 

i) Restart all VMs 

Note: Live Migration can only be accomplished through the “Failover Cluster Manager”, not through 

“Virtual Machine Manager” 

Appendix: Intel® Cloud Builders Reference Architecture 

Refer to the Intel® Cloud Builders Reference Architecture: Microsoft System Center Virtual Machine 

Manager Self-Service Portal* 2.0 with Policy-Based Power Management for an example of how to 

configure a private enterprise cloud.  

  

http://www.esaa-members.com/app/webroot/recipes/40MSFT90CLOUD00000-01.pdf
http://www.esaa-members.com/app/webroot/recipes/40MSFT90CLOUD00000-01.pdf
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Support Information 

Please contact the vendor for any support issues with application software or third-party hardware used in 

recipe configurations. Intel customer support does not provide support for third-party software or hardware-

related issues. Calls received by the Intel support site will be referred to the appropriate vendor. 

Intel hardware support information 

Intel® ESAA – Your Recipe for Success 

Collaborative Validation.  Reliable Solutions.  Complete Confidence. 

When you choose a validated server solution available through 

the Intel® Enabled Solutions Acceleration Alliance (Intel® ESAA), 

you choose a solution that delivers the highest standards for 

quality and interoperability. Through this collaborative alliance, 

Intel Corporation has teamed with other industry leaders to 

provide you with server solutions that meet a range of business 

needs. Intel® ESAA provides a process to streamline deployment 

and implementation so you can focus on growing your business. 

For more information about the Intel® ESAA program, visit 

www.intel.com/go/esaa. 

 

http://www.intel.com/support/9089.htm
http://www.intel.com/go/esaa

