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Main: +1 617-833-4242 
Support: +1 800-329-0223 

Fax: +1 617-926-2808 
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Please read the terms and conditions of the Agreement before commencing use of the software program. 
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About Sanbolic® Melio™ 
 
Sanbolic Melio  is a comprehensive, distributed data management platform comprised of several 
advanced software components that work together to significantly enhance the performance, 
scalability, availability and management of enterprise workloads in virtual datacenters and private 
cloud deployments. 
 
Running natively on Windows® Server OS platforms, Melio installs on physical and virtual Windows® 
servers (hosted by popular hypervisors including Microsoft® Hyper-V™, VMware® vSphere™ and 
Citrix® XenServer™), is server and storage hardware agnostic, and works with all block-based 
protocols (i.e., iSCSI, Fibre Channel, FCoE, Infiniband, etc.). 
 
At the core of Melio is an all-purpose, 64-bit, symmetrical cluster file system called Melio FS™ that 
allows multiple Windows® servers to share simultaneous read-and-write access to data stored on the 
same partition or Logical Unit Number (LUN) on SAN (block-based) storage. 
 
A cluster volume manager called Melio Volume Manager™ is also included with the Melio software. 
Melio Volume Manager greatly simplifies management of Melio shared volumes while enabling 
advanced storage management functionality crucial for enterprise and private cloud environments. 
 

��������������������������������
 
The following sections provide instructions for installing and using the Melio software to create shared 
storage for Windows® platforms. 
 
�����������������������������
 

�  Pentium IV class processor or equivalent 
�  512 MB RAM 
�  24 MB free disk space 
�  LAN (TCP/IP) connection 
�  SVGA – min. 800x600, 256 colors 

 
�����������������������������
 

·  Windows Server 2003 x64 
·  Windows Server 2003 R2 x64 
·  Windows Server 2008 x86, x64 
·  Windows Server 2008 R2 

 
Note:  Windows Server 2003 x86 and Windows Server 2003 R2 x86 are not supported. 
 
Note:  Melio 4 requires .NET Framework 3.5 SP1. Please ensure that .NET Framework 3.5 SP1 is 
installed on your computers prior to installing the Melio software. 
 
Note:  Melio 4 uses multicast (IGMPv1) for node discovery and cluster formation. In order for Melio 
computers to discover one another and form a cluster, multicast must be enabled on all managed 
network switches and routers between the computers. For networks that do not use/support multicast, 
an update to Melio 4.x (v4.0.5) includes a feature called “UDP subnet scan” that allows Melio 
computers to discover one another without requiring multicast. You can learn more about this feature 
later in this section. 
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 Melio uses a proprietary communications protocol (based on TCP and UDP) for file system 
and volume management. To mitigate or remove the potential for heavy network traffic to 
adversely affect Melio communications, Sanbolic strongly recommends the use of a private or 
stand-alone network for Melio. This dedicated network can be created using a crossover cable 
for a two-node cluster or an Ethernet switch for clusters comprised of three or more nodes. 
 

 To achieve even greater levels of performance, scalability and availability, while simplifying 
the management of Melio shared storage, Sanbolic strongly recommends using Melio Volume 
Manager to create and manage Melio shared volumes. Designed for shared storage, Melio 
Volume Manager allows administrators to create basic partitions, volume sets, stripe sets and 
mirror sets and take advantage of advanced storage features such as RAID1, RAID10, live 
storage migration and dynamic volume expansion. 

 
������������� !�	"������
 

·  Using an account with local administrator privileges, log on to the system in which Melio is 
going to be installed. 

·  Verify that the Windows Management Instrumentation (WMI) service is running. 
·  Verify that the system has IP connectivity to the network (LAN) that will be used by Melio for 

cluster administration. 
·  Using the instructions provided by the manufacturer of your storage hardware, install and 

connect your storage hardware to the servers that will be running Melio. Once you’ve 
confirmed the storage hardware is operating correctly, create one or more LUNs and map 
them to the servers. Check the event logs on the servers for any storage connection-related 
error messages and resolve all reported errors prior to installing Melio. 

·  Verify that the LUN(s) to be formatted with Melio FS is seen by Windows. To accomplish this, 
open a DOS prompt and enter the following commands:  

o diskpart <enter> 
o list disk <enter> 

·  You should see the LUN(s) in the list of disks. If not, check the connection(s) between the 
server(s) and the storage and confirm that the LUN(s) has been mapped to the server(s) from 
the storage. 

·  Verify that the LUN(s) to be formatted with Melio FS is not configured for “Read-only” mode. 
To accomplish this, enter the following commands in diskpart: 

o select disk # <enter>   (# equals the number assigned to the LUN) 
o attributes disk <enter> 

If the LUN(s) is set to “Read-only” mode, enter the following commands: 
o attributes disk clear readonly <enter> 
o attributes disk <enter> 

The LUN(s) should now appear with “Read-only” set to “No”. 
·  Download and save the Melio 4 setup program on the desktop of your servers. 
·  If a prior version of Melio is already installed, please refer to Tech Brief 

http://blog.sanbolic.com/?p=2732 to review best practices for upgrading your Melio software. 
·  Beginning with Melio 3.5, license keys are applied to volumes. Please refer to Tech Brief 

http://blog.sanbolic.com/?p=2155 to learn more about licensing your Melio software. 
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Double-click the Melio setup program on a server running one of the supported operating systems 
listed under the Supported Operating Systems
 
A security warning will be displayed:
 

 
Click “Run” to proceed with the installation.
 
A "Welcome" screen will be displayed:
 

 
Click “Next” to continue with the installation.
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click the Melio setup program on a server running one of the supported operating systems 
Supported Operating Systems  section on the previous page. 

A security warning will be displayed: 

 

“Run” to proceed with the installation. 

"Welcome" screen will be displayed: 

Click “Next” to continue with the installation. 

click the Melio setup program on a server running one of the supported operating systems 
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Select “I accept the agreement” to accept the license agreement and click “Next” to continue. 
 
The “Upgrade Information” window will appear: 
 

 
 
If Melio is being installed for the first time, select “This is a new installation – continue” and click “Next”. 
 
If a prior version of Melio is already installed and you are running the Melio setup program to upgrade 
the Melio software, please refer to Tech Brief http://blog.sanbolic.com/?p=2400 to review best 
practices for upgrading your Melio software. 
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In the “Select Destination Location” window, select an installation folder for the Melio software and 
click “Next”. 
 

 
 
Select the components you would like to install and click “Next”. 
 
Note: In order to use the Melio software, at a minimum the radio button for Melio FS / Melio Volume 
Manager must be selected. 
 
In the “Configure Windows Firewall” window, leave the default option to open port 7777 for TCP and 
UDP communications checked to allow the Melio software to function properly. 
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Note:  If you decide to change the IP/port pair (socket) used by Melio at a later time, the Melio software 
will automatically reconfigure Windows Firewall to accommodate for the new settings. 
 
If you are using a third party firewall, you will need to configure the port exceptions manually to ensure 
the Melio instances running on the servers are able to communicate with one other. 
Note:  If any instance of Melio is unable to communicate with the Melio instances running on the other 
servers in a cluster, that server will not be able to access any volumes formatted with Melio FS. 
 
Click “Next” to continue. 
 

 
 
In the “Select Accounts for Melio Disto and SILM” window, enter the machine account(s) that will be 
used by the Melio Volume Manager to manage Melio shared volumes and the SILM™ data mover 
utility to copy or move files based on user-defined policies (see SILM Users Guide) and click “Next”. 
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In the “Ready to Install” window, click “Install” to install the selected components. 
 
Note:  If the setup program prompts you to reboot your computer to complete the installation, click 
“OK” to reboot your computer. After the computer reboots, the setup program will display the “Ready 
to Install” window. Click “Install” to install the selected components. 
 

 
 
Click “Finish” to complete the installation of the Melio software. 
 
After the setup program is completed, the Melio driver will start. 
 
Note:  All Melio components selected during the installation will appear under the Start menu (Start > 
All Programs > Sanbolic). 
 
Repeat the installation process on all computers that will share access to Melio volumes. 
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Once Melio is installed on all computers, proceed to Managing a disk with Melio Volume Manager  
(below) to create your shared storage. 
 
#�����$�������
 
During the Melio software evaluation you will receive a trial key that activates the Melio software on a 
per volume basis. With the trial key, you can activate a maximum of two volumes for 15 days. Upon 
trial expiration, all Melio shared volumes will transition to “read-only” mode and only one server will be 
allowed to access the volumes. To continue using the Melio software, a permanent license key will be 
required. To obtain a permanent license key, please contact your Sanbolic reseller or Sanbolic sales 
representative at sales@sanbolic.com. 
 
��������������"�%��!�������$��������������
 
Note:  Prior to managing a disk with Melio Volume Manager, at least one partition (LUN) on your SAN 
storage must be provisioned and presented (mapped) to every computer running the Melio software. 
 
Launch the Melio Volume Manager (Start > All Programs > Sanbolic > Melio Volume Manager). 
 
By default, the local computer running Melio will be displayed on the left-hand side of the Melio 
Volume Manager console. 
 
 

 
 
UDP subnet scan  - To configure Melio to search for and discover other Melio computers on the 
network (LAN) in order to for a cluster without multicast, highlight the local computer on the left-hand 
side of the management console, select “View > Driver Settings” from the toolbar at the top and under 
the “Network” tab, check the box “UDP subnet scan”. This option should only be selected when 
multicast (IGMPv1) is not enabled on the network switches and routers on your network. (See screen 
on following page.) 
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Right-click on the disk label (where it says “Empty”) in the center window pane and select “Manage” to 
manage a single disk or “Manage Multiple” to manage multiple disks. 
 
A pop-up window will appear asking you to select the disk(s) that you want Melio Volume Manager to 
manage. 
 
Note:  Unless advised by Sanbolic Technical Support, you should NOT make any changes to the 
values of the parameters listed under the “Timings” section. The default values are designed to work 
under the majority of use cases. (Descriptions for these parameters are provided later in this manual.) 
 

 
 
Select the disk(s) to manage and click “OK.” 
 
Note:  If you are going to use the entire capacity of the disk(s) to create your Melio shared volume, you 
can select the option “Automatically create full-size basic partition on each disk”. Additionally, if you 
are going to create a stripe set using the selected disks, you can select the option “And stripe them”. 
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If you are going to use only a portion of the capacity of the disk(s) or plan to use the disk(s) to create a 
volume set or mirror set, simply click “OK”. 
 
Note:  After clicking “OK” to manage the selected disk(s), a message will appear informing the user 
that the process of managing the disk(s) will take approximately fifteen minutes. Please do not attempt 
to cancel this process until it has completed successfully. 
 
After the process of managing the disk(s) has completed, the following screen is displayed. 
 

 
 
To create a partition on a managed disk, right-click on the disk (where it shows “Empty”) and select 
“New.” 
 

 
 
Leave the size as it appears to create a partition using the entire available disk space or specify the 
desired partition size by entering numbers in the “Size” field or using the red slider bar. 
 
Enter a label for the partition. (Optional) 
 
When you are ready to create the partition, click “OK”. 
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Once this step is completed, the new partition will appear in blue in the upper center window pane. A 
blue partition indicates that the partition is ready to be created. (See illustration on following page.) 
 
To create the partition, select “Action > Apply Changes” from the toolbar or press F3. 
 

 
 
A pop-up window will be displayed asking for confirmation. Click “Yes”. 
 

 
 
Once the changes are committed to the disk, the color of the partition will change to black, indicating 
that the partition has been created. 
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Now the partition can be converted to a logical drive (volume) that can be mounted and accessed by 
multiple computers simultaneously. 
 

 
 
Right-click on the partition in the upper center window pane and select “Create Logical Drive…” 
 
A dialog window will appear asking you to assign a drive letter to the new volume. The setting "Try to 
set this letter, if available, on each machine that has access to the volume" means the Melio Volume 
Manager will attempt to supply Windows with the same drive letter for this volume on all machines that 
will be sharing access to the volume. If the drive letter is already in use by a machine, Melio Volume 
Manager will assign the volume the next available drive letter on that particular machine. It is also 
possible to mount a Melio volume on an empty Melio FS or NTFS folder using mount points. To mount 
a volume on an empty folder, check the radio button labeled “Mount to an empty folder” and enter the 
path to the folder. 
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Under “Initial Security,” leave the option “Give everyone full control” (default). 
 
Leave the “Format with Melio FS” button checked (default). 
 
In the “License key” field, enter your 13-character license key, separated by hyphens (see illustration 
on previous page). 
 
Note:  If you are using the “Sanbolic Private Activation Server” volume activation method, enter the 
name or IP address and port number (ex. 192.168.1.100:7780) of the computer running the Sanbolic 
Private Activation Server service. 
 
Enter a label for the volume in the “Volume Label” field. (Optional) 
 
Click “OK” to create the volume. A window containing messages about the volume creation process 
will appear. 
 
Note:  During the volume creation process, if Windows prompts you to format the volume, click 
“Cancel” as the volume is already being formatted with Melio FS. 
 
Note:  If Windows prompts you to restart the machine, click “Cancel”. Restarting the machine is not 
necessary. 
 
Once the volume has been created, a message will appear in the window stating that all steps have 
completed successfully. Click “OK” to close the window and return to the Melio Volume Manager. 
 
Notice:  A disk that cannot be managed by the Melio Volume Manager is displayed as “Unknown” or 
“Foreign”. This indicates that another volume manager is actively managing the disk. To manage the 
disk with the Melio Volume Manager, it must first be unmanaged by the other volume manager. To 
accomplish this, you need to delete all partitions on the disk. If the disk is “dynamic,” you must convert 
it to a “basic” disk using Windows Disk Manager. Note that deleting partitions on a disk or converting a 
disk from dynamic to basic will delete all data stored on the associated volume. Make sure that any 
data you need is backed up to another volume PRIOR to deleting partitions or converting disks. 
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On your storage controller, create at least two LUNs of identical size. 
 
Note:  All partitions making up a stripe set must  be exactly the same size. 
 
Follow the instructions provided in the previous section to create at least two partitions managed by 
the Melio Volume Manager. 
 

 
 
Right-click in any open area in the upper center window pane and select “New > Stripe Set”. 
 

 
 
A pop-up window will be displayed, asking for the size of the stripe set. By default, the stripe size is set 
to 64 KBs, which corresponds to the default stripe size of most contemporary disk arrays. 
 

 
 
A new empty placeholder for the stripe set will appear in the upper center window pane. 
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Add the partitions to the stripe set by left-clicking on them (one at a time) and dragging and dropping 
them onto the stripe set. 
 
From the toolbar, select “Action > Apply Changes” to create the stripe set. 
 
To make the stripe set visible to Windows as a logical drive (volume), follow the steps described 
previously to create a logical drive. 
 
 ����������$����������
 
To create a volume set, follow the same steps used to create a stripe set, only this time, right-click on 
any empty space in the upper center window pane and select “New > Volume Set”. 
 
Note: Unlike stripe sets, the partitions making up a volume set do not have to be the same size. 
 
Drag and drop partitions onto the volume set placeholder and select “Action > Apply Changes” from 
the toolbar to create the volume set. 
 
To make the volume set visible to Windows as a logical drive (volume), follow the steps described 
previously to create a logical drive. 
 
 ���������������������&�'�()*�
 
Follow the instructions provided earlier to create at least two partitions managed by the Melio Volume 
Manager. 
 
Note:  The partitions making up a mirror set must be exactly the same size. 
 
Right-click on one of the partitions and choose “Mirror” > “Create…” 
 

 
 
In the “Make Mirror” window, select the other partition that will be used for the mirror and click “OK”. 
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The mirror will appear in blue. 
 

 
 
From the toolbar, select “Action” > “Apply Changes” to create the mirror set. 
 
The mirror will appear in orange, indicating that it is synchronizing. 
 

 
 
Once synchronization has completed, the mirror will appear in green. 
 
You can now create a logical drive (volume) on the mirror set. 
 
To make the mirror set visible to Windows as a logical drive (volume), follow the steps described 
previously to create a logical drive. 
 
Once the logical drive has been created, the mirror will resynchronize. 
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After synchronization has completed, the logical drive (and its partitions) will appear in green, 
indicating it is ready for use. 
 
�������$����������������

An existing volume can be mirrored while the volume is mounted and active. The volume will continue 
to be operational during the mirror creation and synchronization process.�

 
 

 ����������+��!���',��������$������

When a volume structure is mirrored and contains more than one mirror, the volume can remain online 
and accessible even if some disks are missing. In order for this to occur, there must be at least one 
functional pair of mirrored disks and the disks participating in the failed mirror set must have 
participated in the last volume mount. 
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With a missing disk, volume B: is still online and operational. 
 
To break a mirror, right-click on the mirror set and select “Mirror” > “Break…” 
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Create two mirror sets as described in the previous section. 
 

 
 
Then create a new stripe set and drag and drop the two mirror sets (one at a time) onto the strip set. 
 
From the toolbar, select “Action > Apply Changes”. 
 
The two mirror sets will now appear under the stripe set. 
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To make the stripe set visible to Windows as a logical drive (volume), follow the steps described 
previously to create a logical drive. 
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To break a mirror, right-click on the mirror set and select “Mirror” > “Break…” 
 

 
 
Select a partition to remove from the mirror set and click “OK”. 
 
From the toolbar, select “Action > Apply Changes”. 
 
The logical drive will now be left with a single partition. 
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When a volume is comprised of a single mirror set and one of the disks in the mirror fails, the volume 
will become inaccessible. To make the volume accessible, follow the instructions provided above to 
remove the failed disk and break the mirror. Once the failed disk is removed from the mirror, the 
volume will become accessible.�
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A mirror set can be broken while its volume is mounted and active. To break the mirror, the mirrored 
pair of disks must be fully synchronized. Follow the instructions provided above to remove one of the 
disks and break the mirror. The volume will continue to be operational while the disk is being removed 
from the mirror and after the mirror has been broken.�
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Additional storage (i.e., partition, volume set, stripe set or mirror set) can be added to an existing 
volume without disrupting its operation. This process creates a volume set comprised of the original 
volume and the newly added storage. 

To extend a volume (logical drive), follow the instructions provided previously to create a new partition, 
volume set, stripe set or mirror set and apply the changes. Drag and drop the new partition/volume 
set/ stripe set/mirror set onto the volume that you want to extend and apply the changes to extend the 
volume. Once the volume is extended, it will be displayed (with its new size) as a volume set in the 
Melio Volume Manager console. 

Note:  You cannot extend a volume set that contains only basic partitions with a Stripe set. This is due 
to the difference in sector sizes between the partitions and the stripe set. 

Note:  Shrinking a volume is not supported.�
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If you run out of free space on a disk, you may be able to add free space (provided there is unused 
storage resources available and your storage hardware supports LUN extension) using the storage 
management application for your storage hardware. Once the LUN is extended, select “View > 
Rescan Disks” from the toolbar at the top of the Melio Volume Manager to allow Melio Volume 
Manager to recognize the additional disk space. Right-click on the new disk space and select “New” to 
create a new partition. From the toolbar, select “Action > Apply changes” and then drag and drop the 
new partition onto the original volume (logical drive). Apply the change a second time to extend the 
volume dynamically (without rebooting the system). Within seconds, the extended volume will be 
displayed in the Melio Volume Manager console. 

Note:  Shrinking a disk is not supported.�
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Since Melio Volume Manager is a cluster volume manager, it is important to remember that security 
permissions can be applied to a volume only and not to disks, partitions, volume sets, stripe sets or 
mirror sets. A volume is the resource for which users are granted/denied access. Like any other 
protected object in Windows, each volume has a security descriptor that defines user access to it. 
When security permissions can be applied to a particular object, the respective option is enabled in the 
context menu.�
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Two agents can operate with volumes: 
 

1. A machine user account  represents the machine from where the volume is accessed. The 
credentials of the machine user account are necessary in order to start the Melio Volume 
Manager service. The rights of the machine user account define the following: 

a. *������������	
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2. A common user  (i.e., John, Mary, etc.) – Individuals who can make changes, edit 
configurations, etc. To make changes from the User Interface of the Melio Volume Manager, 
the credentials of the common user apply. 

 

Most likely, the machine user account will be the account entered during the installation of the Melio 
software. If this account or its credentials need to be changed, you can make these changes from the 
Melio Volume Manager service tab of the Global Settings dialog. 

Once the Melio volume has been created and activated, open “My Computer” on each computer 
participating in the Melio cluster and confirm that each computer has read-and-write access to the 
shared volume. 
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Important note:  Melio works with “basic” disks only and does not support “dynamic” disks. Converting 
basic disks that will be formatted with Melio FS to dynamic disks can lead to volume instability. 
 
Although Sanbolic strongly recommends managing Melio volumes with Melio Volume Manager, 
volumes managed by Windows Disk Manager or another third-party volume manager can be 
formatted with Melio FS to allow such volumes to be shared amongst multiple Windows servers. It is 
important to note however that such volumes will not be able to take advantage of advanced storage 
features such as volume sets, stripe-sets, mirror sets, dynamic volume expansion and live storage 
migration as Melio Volume Manager is required to utilize these features. 
 
Note:  Prior to formatting a volume with Melio FS, a drive letter must be assigned to the volume, which 
can be achieved using the Windows diskmgmt.msc management console. Make sure the disk has 
been assigned to all machines running Melio that will need to access it. Since Windows Disk Manager 
is not designed to manage shared volumes, it may be necessary to launch Windows diskmgmt.msc on 
each machine and assign the volume a drive letter. 
 
To format a volume with Melio FS, right-click on the associated drive in Windows Explorer and select 
"Melio Format". (See screen on following page.) 
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Note:  Formatting a volume with Melio FS via the Windows context-sensitive (right-click) menu must be 
performed from one machine only. Once the volume has been formatted, all servers running Melio will 
automatically discover and mount the shared volume. 
 
A confirmation message will be displayed: 
 

 
 

Click “Yes” to format the volume with Melio FS. 
 
Formatting a volume with Melio FS may take several minutes to complete. Please allow the formatting 
process to complete before attempting to access the drive. 
Reformatting a volume with Melio FS – If the volume was previously formatted with Melio FS and other 
machines are accessing it, the reformat operation will fail and an error message will be displayed. To 
format the volume, you must ensure it is not in use by other machines and that there are no open 
handles referencing it. The simplest way to accomplish this is to shut down all machines accessing the 
shared volume except the one machine being used to reformat it. 
 
Note: Formatting a volume previously formatted with a file system other than Melio FS is not 
recommended as it could lead to volume performance or stability issues. In the event that a previously 
formatted volume must be used, it is imperative that all machines accessing the volume except one be 
disconnected from the storage or shut down prior to reformatting the volume with Melio FS. 
 
Sanbolic strongly recommends formatting only new (raw) LUNs with Melio FS. 
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The following tasks can be performed using the Melio Shell Extension (see screen on following page): 
 

·  Members  – checks and displays all computers accessing the Melio volume 
·  DFS Sharing  – configures DFS file sharing for file shares on the Melio volume 
·  Opened Files  – checks and displays a list of all currently open files on the Melio volume 
·  Start Repair  – attempts to repair the layout of the Melio volume 
·  Shadow copies  – creates, deletes, opens or schedules snapshots of the Melio volume 
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Melio is a shared file system that supports all standard file system operations such as creating, 
copying, moving, renaming and deleting files and directories, reading from and writing to files, 
changing file and directory attributes, locking whole files or particular sections only, etc. 
 
Since Melio is a shared file system, all of the above operations can be safely performed on a volume 
by multiple machines simultaneously. 
 
At the core of Melio is a kernel level driver whose functionality is accessed indirectly through Windows 
Explorer and all user applications using operating system commands such as "copy" or "dir" or via the 
standard Win32 programming functions such as CreateFile(). Melio is tightly integrated with Windows 
Server 2003 and 2008 operating systems and supports all commands and system API functions 
natively. Thus an application that works with NTFS will also work with Melio. 
 
Melio is a fully-journaled file system, which means that all metadata changes are recorded in a special 
area on the disk called a journal (transaction log). If a machine crashes for example, the file system 
may be left in a non-consistent state, potentially leading to data corruption. To prevent this, all 
interrupted operations are checked and replayed using the journal as soon as the volume is accessed 
by one of the machines in the cluster (not necessarily the crashed machine). It is important to note 
that, depending on the number of operations that were taking place during the failure, the process of 
replaying a journal can take some time and during this time delays in I/O operations can be expected. 
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Additional parameters can be configured within the Melio Configuration utility (Start > All Programs > 
Sanbolic > Melio Configuration). 
 
Important note:  The default parameters and values for Melio are designed to work under the majority 
of configurations. Modifications made to any of the parameters described below should not be made 
without first conferring with Sanbolic Technical Support. 
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Melio uses both TCP and UDP protocols for communications between Melio instances running on all 
machines participating in a Melio cluster. 
 
The subnets that appear under the Network settings (“View > Driver Settings > Network”) in the Melio 
Volume Manger console are used to select the subnet ranges (network interfaces) on which Melio will 
listen. This ensures that Melio is compatible with DHCP servers that may assign a computer different 
IP addresses. 
 
If a machine has more than one IP address (active network interface), a subnet range address should 
be selected. Selecting a subnet range for Melio is done on a per machine basis by opening the Melio 
Volume Manager, selecting a computer on the left-hand side of the console and selecting “View > 
Driver Settings > Network” from the toolbar at the top of the console. If a machine has only one IP 
address, you can leave the default subnet range setting “0.0.0.0/0”. 
 
Melio uses the specified multicast address to find other cluster members. Each Melio instance listens 
on the multicast address at the port specified under the Network settings. In order for Melio to form a 
cluster with machines located on different subnets, all intermediate routers must be configured to 
forward multicast packets between subnets. 
 
Note:  If you experience network problems when Melio is used with Windows® Failover Clustering, 
select a different multicast address for Melio. Make sure you use the same multicast address on all 
members of the Melio cluster. 
 
Note:  Melio supports Dynamic Host Configuration Protocol (DHCP) and IPv6. 
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Disk Flush Disabled - Setting this option may help in situations where hardware issues exist. Certain 
disk storage does not support this command or support it effectively (usually when the command is 
issued it takes a lot of time to be completed by the underlying storage). When checked, Melio will not 
issue disk flush commands. If unsure, leave unchecked. 
 
Pre-allocation Disabled – Setting this option is not recommended unless advised by Sanbolic 
Technical Support. 
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These times affect the operation of all machines participating in a Melio cluster. The parameters are 
volume-specific and once changed, are written to the respective volume and propagated throughout 
the entire cluster. 
 
Note: Cluster Times values are written directly on the volume, which requires that the volume be 
locked temporarily by one machine. This will make the respective volume inaccessible to all other 
machines in the cluster for a short time while the changes are written. Also, you must ensure there are 
no open files and/or handles for this volume on the other machines, as this will prevent the volume 
from being locked. If there are any open files and/or handles for the volume, the message "Failed to 
lock volume. Access is denied." will be displayed. Note all times are in milliseconds. 
 
Max IO Time - This is the maximum time an operation to or from the shared disk can last. 
Heartbeat Period - This is the time interval at which the heartbeat check is invoked. 
Max Net Roundtrip - This is the maximum time in which a machine expects to receive an answer 
from the other computers in the cluster to its request over the TCP/IP network. 
Max OS Response Delay - The interval between the expected start of a system operation in the 
computer and its real start. Unless the computer is under constant 100% load, this value should not be 
changed. 
Min Crash Recovery Delay - This is the minimum time it takes for the cluster to determine that a 
machine is not responding and evict it from the cluster. While this process takes place, I/O operations 
may be disrupted, depending on the file system’s read/write pattern. This is because machines must 
refrain from changing data on the disk in order to ensure its integrity. This delay depends on all the 
preceding parameters. It cannot be directly changed and is calculated based on the other values. 
 
Clicking the "Reload " button refreshes the volume values. After applying changes to Cluster Times 
values, press the “Reload ” button to see the latest values. 
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Using the registration window (see screen below) you can transition the operational mode of Melio 
from “Trial” to “Full” mode, apply a new Melio license to upgrade to another edition of Melio, or check 
which features are currently enabled. 
 
Transitioning from “Trial” to “Full” mode takes place dynamically. Simply enter the user name, 
company name and serial number and click “Apply.” 
 
Note:  Every machine participating in a Melio cluster that is running in “Full” or “Registered” mode 
must  have a unique license key installed. Machines using the same license key will be removed from 
the cluster and will not be able to access any Melio shared volumes until unique license keys have 
been applied. Running different editions of Melio on machines participating in the same cluster is also 
not supported. In either of these situations, a message will be written to the System event log. 
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There are a number of settings that affect the way a process behaves. 
 

·  Report fs as NTFS – Specifying a value other than zero enables this setting, which some 
applications may require in order to work properly with Melio. 

·  Disable Access Time Update - Specifying a value other than zero enables this setting, which 
suppresses the "Date accessed" property of files. With this parameter enabled, a significant 
increase in performance may be observed when working with files and/or directories, i.e., 
viewing directory contents, reading files, opening multiple files, etc. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 
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·  Block application access - Specifying a value other than zero enables this setting, 
preventing the specified application from accessing the file system. 

·  Ignore Write Through - Specifying a value other than zero enables this setting, causing the 
file system to ignore the FILE_FLAG_WRITE_THROUGH. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 

·  Ignore No Buffering - Specifying a value other than zero enables this setting, causing the file 
system to ignore the FILE_FLAG_NO_BUFFERING. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 

·  Enforce Write Through - Specifying a value other than zero enables this setting, which 
enforces the FILE_FLAG_WRITE_THROUGH. This setting may fix fluctuations in the 
performance of certain applications, i.e., video applications. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 

·  Enforce No Buffering - Specifying a value other than zero enables this setting, which 
enforces the FILE_FLAG_NO_BUFFERING. This setting may fix fluctuations in the 
performance of certain applications, i.e., video applications. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 

·  Dirty Page Threshold – Specifying an integer value informs the system of the threshold for 
dirty pages within the system’s cache before they are flushed. For example, if there are 
multiple files opened by the specified process, this setting will affect the dirty pages of each 
file. The default value is 0, indicating there is no threshold. This setting is on a per file basis. 

Warning: This parameter should only be enabled when instructed by Sanbolic technical support!!! Enabling 
this parameter on your own accord may present undue risk. 

·  Allow Open Paging File 
·  Strict Write Through 
·  Ordered Asynchronous NO_BUFFERING IO`s 
·  Cluster Size [bytes] 

 
The settings that correspond to the [Default] process are global settings* - they affect all processes. If 
a process is added, its settings will override the global ones. 
 
You can add a process by right-clicking in the Process pane. This will allow you to browse for the 
executable file. To add the preferred settings, you must select the desired process first and then right-
click in the "Tweaks for process" window pane. You will notice that the relevant process is displayed 
after "Tweaks for process". 
 
* Note: It is not recommended to change global settings as this may lead to unexpected behavior of the file 
system. Instead, changes should be made on a per process basis. 
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These tweaks manage the behavior on a per volume basis. These can be set globally for all Melio 
volumes by using them on the [Default] placeholder or individually for each volume available. 
 
There are two per volume tweaks. 
 

1. Quality of Service /QoS/ - Select the appropriate volume, right click in the "Tweak Name" 
column and choose "Add Enable QoS" from the menu. A value of 1 (enabled) will be added to 
the tweak. Note:  QoS is disabled by default. 

2. Level 1 batch oplocks. Enabling this tweak (specifying a value other than zero) disables Level 
1 batch oplocks on the specified volume. 
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To use this feature, please enable it as described in “Per Volume Tweaks.” QoS allows a user to 
assign a specific amount of the total throughput available in a storage controller to one or more 
processes running on a machine and/or one or more VHDs. 
 
Priorities are managed by a point system starting with the lowest priority (1) and ending with the 
highest priority (1000). You can add a process by right-clicking in the Process window pane, which will 
allow you to browse for the executable file. To add the preferred settings right-click, select a process 
and edit the “Points” column by entering the desired value. 
 
The following is an example of how to use QoS: 
 
There are two processes – A and B, both of which are bandwidth intensive, and two other processes – 
C and D, which do not require as much bandwidth. Here is a scheme of the processes points: 
 
A – 10 points 
B – 10 points 
[Default] – 5 points 
C – 1 point 
D – 1 point 
 
Based on the above described point scheme, with Process A and Process C running at the same time, 
IO bandwidth will be redistributed between them as follows: Process A will have 9/10 (90%) of the 
bandwidth reserved, while Process C will have only 1/10 (10%) of the bandwidth. 
 
QoS by Filename works in conjunction with the per process scheme described above. Points assigned 
to a file/file group/folder are added to the ones for the process and then bandwidth reservations are 
calculated as above. If wildcards are used to generalize particular types of files, the process accessing 
them will get points added for all of them as a whole. Of course QoS can be set on a file by file basis 
by assigning weights to individual files, not groups. 
 
It is important to note that every process participating in QoS computation has points assigned - either 
explicitly set or using the default. 
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You can obtain a registered version of Melio with partial or all features enabled. Melio offers the 
following features: 
 
Number of machines allowed simultaneous access to a  volume – Licenses can be purchased that 
allow a specific number of machines or an unlimited number of machines to share access to one or 
more Melio volumes. 
Modify security – With this feature enabled, you can modify the files and directories security. 
Extend volumes – This feature allows you to extend Melio shared volumes. Note the ability to extend 
a Melio volume is only available when the volume is managed by Melio Volume Manager. 
Reparse points – Enabling this feature will allow a user to make use of the reparse points’ 
functionality. 
Sparse files – These are files that are mostly empty, enabling this feature allows you to use software 
that requires sparse files. 
Modify cluster affinity – Cluster Affinity allows a specific cluster machine (or group of clustered 
machines) to keep the connection to a shared volume after it has lost communications with the 
remaining machines participating in the cluster. 
QoS – This feature can be used to define how storage throughput is shared amongst applications 
accessing a particular volume. QoS can be set on a process or file/class of files basis. 
Extended file attributes – Allows users to associate computer files with metadata not interpreted by 
the file system. This feature enables NTFS compatible extended file attributes on Melio. 
Open file by ID – File ID is a 64bit reference number for a file. This number is assigned by and 
specific to a particular file system. An application can use a file_id to open the corresponding file. 
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Windows folder and file sharing – This feature allows files and folders stored on Melio shared 
volumes to be shared via file-sharing protocols (i.e., CIFS or NFS). 
Hard links  – Directory entry that associates a name with a file on a file system� 
Quota  – Specify access permissions to Melio shared volumes for Windows users or groups. 
 

 
 
Volume shadow copy (Snapshot)/ Writable Snapshot – The snapshot capability allows fully-
journaled snapshots to be created from any machine in the cluster. The snapshot capability supports 
standard APIs and can be invoked by industry-standard VSS backup software. (See screen below.) 
Full volume layout repair  – Supported in Melio from Melio Shell Extension. (See screen below.) 
DFS File-sharing: Beginning with Melio 4.0.5, support for creating file shares (accessible via DFS 
Namespaces) on Melio volumes is supported. (See screen below.) 
 

 
 
Per-volume activation with dynamic server-side feat ure selection  – Melio is licensed on a per-
volume basis, which can be activated online or manually via the Melio FS Configuration UI. 
SCSI reservations  – Melio supports SCSI reservations. 
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set_cluster_affinity.exe* – This utility is located in the Melio installation folder (C:\ Program 
Files\Sanbolic\Melio\ by default) and is used for cluster affinity feature administration. Weights can be 
assigned on the same Melio volume from different machines. By default all volumes on all machines 
have a cluster weight of 1, making them equal. The syntax is as follows: 
 
set_cluster_affinity.exe \\.\x: <weight> or 
set_cluster_affinity.exe \\?\Volume{dab8cf5f-eede-11d9-935e-0011d89ce0a0} <weight> 
 
In case of TCP/IP network connection loss between one or more machines, the cluster can split into 
several isolated clusters attempting to access the shared volume. Normally this can lead to a split-
brain situation in which different cluster groups think they own the same volume exclusively, which can 
result in data corruption. To prevent this situation from occurring, fencing mechanisms are used to 
dismount the volume on “misbehaving” machines. When cluster affinity is set, weights are summed up 
and the heaviest cluster (highest total weight value) becomes the current owner of the volume, with all 
remaining machines removed from the cluster. 
 
For example, if you set the weight for a particular volume on one of the machines greater than the 
number of cluster members and deliberately disrupt the network connection between them (i.e., 
changing the Melio TCP/UDP port number), all machines except the one with the heaviest weight will 
leave the cluster. 
 
Note: Cluster affinity is available in Melio Enterprise and Melio Private Cloud editions and will return an 
"Incorrect function" error message in the Melio VDI  edition. 
 
vss_client.exe* – This utility is located in the Melio installation folder (C:\ Program 
Files\Sanbolic\Melio\ by default) and allows the manipulation of the cluster wide Melio VSS compatible 
snapshots. Below is a list of supported commands: 
 
Create Shadow - create a new volume shadow copy 
Delete Shadows - delete volume shadow copies 
Delete ShadowSet - delete an empty shadow set 
List Shadows - list existing volume shadow copies 
List Providers - list registered volume shadow copy providers 
List Volumes - list volumes eligible for shadow copies 
Expose Shadow - expose the shadow copy as a regular mount point or a network share 
Unexpose Shadow - remove an exposed shadow copy 
The syntax is very similar to the default vssadmin Volume Shadow Copy Service administrative 
command-line tool included in all Windows operating systems supporting VSS. For example, to create 
a volume shadow copy of a Melio volume: 
C:\Program Files\Sanbolic\Melio >vss_client.exe create shadow /for=X: 
Melio Volume Snapshots management tool. 
Successfully created shadow copy for 'X:' 
Shadow Copy ID: {ae24550c-446e-4f60-b8e8-634d1ff3c56b} 
Shadow Copy Volume Name: \\?\GLOBALROOT\Device\Volume{ae24550c-446e-4f60-b8e8-
634d1ff3c56b} 
Then the shadow copy can be deleted, exposed as a network share, etc. 
 
Note:  All editions of Melio include Sanbolic Simple Information Life Cycle Manager  (SILM), which 
can be found under the Sanbolic start menu (Start > All Programs > Sanbolic > SILM). SILM is a GUI 
driven utility that allows administrators to create data management policies (i.e., copy or move data 
from one volume to another at block-level) that can run automatically based on predefined schedules. 
For more information regarding the use of SILM, please refer to the SILM User’s Guide. 
 
Important note:  For important information on the use of snapshots with Melio volumes, please refer to 
the following tech brief: http://blog.sanbolic.com/?p=2500. 
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Beginning with Melio 4.0.5, support for creating file shares (accessible via DFS Namespaces) on Melio 
volumes is supported. To create DFS file shares on Melio volumes, perform the following steps: 
 
From “My Computer,” right-click on the Melio volume, select “Properties” and click the “Melio FS” tab. 
 

 
 
Click the “DFS Sharing” button. 
 

 
 
If the DFS feature is not installed or the DFS service is not started, a message will appear asking the 
user to install the DFS feature and/or start the DFS service in order to proceed with the creation of file 
shares on the Melio volume. 
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In the “DFS Sharing” configuration window, enter the Share name, DFS Namespace type and Domain 
Administrator account credentials (if Domain-based Namespace is selected). 
 
Stand-alone Namespace 
 
To create a Stand-alone Namespace, enter the Preferred Share name, select “Stand-alone 
namespace” for the DFS Namespace type, and click “Apply” to apply the changes. 
 
At the top of the window, a message will appear indicating the configuration is “In progress”. 
 

 
 
After several seconds, the Stand-alone Namespace will be created and the computer on which the 
namespace was created will appear with the status “online”. 
 

 
 
Once the file share(s) has been created, network clients will be able to access the share(s) via the 
DFS Namespace through the computer accessing the Melio volume. 
 
Domain-based Namespace 
 
To create a Domain-based Namespace, enter the Preferred Share name, select “Domain-based 
namespace” for the DFS Namespace type, check the “Enable Windows Server 2008 mode” check 
box, enter the user name and password for an account with domain administrator privileges, and click 
“Apply” to apply the changes. 
 
 At the top of the window, a message will appear indicating the configuration is “In progress”. 
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After several seconds, the Domain-based Namespace will be created and the status for all the 
computers in the Melio cluster (accessing the Melio volume) will appear with the status “online”. 
 

 
 
Once the file share(s) has been created, network clients will be able to access the share(s) via the 
DFS Namespace through any computer accessing the Melio volume, enabling high availability and 
load-balancing for the file share(s). 
 
To change the credentials for the Domain Administrator account assigned to a Domain-based 
namespace or to change the Domain Administrator account itself, click the “Domain Administrator 
Account” radio button to activate the “User name” and “Password” fields. Make the appropriate 
changes and click “Apply” to apply the changes. 
 
To remove a Stand-alone or Domain-based Namespace, select the option “Not shared” for the DFS 
Namespace type and click “Apply” to apply the change. 
 
After several seconds, the status for the computer(s) hosting the namespace will transition from an 
“Online” state to an “Outside” state and the namespace will be removed. 
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This section includes steps that can be performed if issues arise when using Melio shared storage. 
 

·  First, make sure that your storage hardware is working properly. Check the system and 
application event log for error messages. If there are timeouts, controller or device errors, or 
something else, fix them according to your storage manufacturer’s guidelines. 

·  Confirm that all machines participating in the cluster are running in the same mode (Trial or 
Full). If the machines are running in Full mode, ensure that each machine is using a unique 
license key for the same edition of Melio (i.e., Melio Enterprise, Private Cloud or VDI). Mixing 
different editions in the same cluster is not supported. To check which mode and edition of 
Melio is running, go to Start > All Programs > Sanbolic > Melio Configuration > Help > About. 

·  Confirm network connectivity between all the Melio machines in the cluster. This is especially 
important on multi-homed systems (systems with several IP addresses). Make sure Melio 
uses the correct IP addresses on the machines so Melio instances can communicate across 
the network. Also ensure that all Melio instances are set to the same port number (this applies 
to both TCP and UDP). 

·  Check the Event log for messages generated by Melio. The file system reports information, 
warning and error messages in the System event log that can offer insight regarding how to 
proceed with troubleshooting (i.e., network connectivity issue, disk array problem, etc.). 

·  Check the version of Melio being used via Help > About in the Melio Configuration tool. This 
will help you determine if you need to download an update for Melio. 

·  If you experience any anomalies, you can compare Melio with NTFS by running the same 
operations on an NTFS volume. If both file systems behave the same, then this is the intended 
behavior and is not indicative of a problem. 

·  Refer to Sanbolic technical briefs at http://blog.sanbolic.com/?cat=52. 
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When you submit a support request, please refer to the following guidelines: 
 
1. Supply information on your hardware and software. 
2. Supply the exact Melio version. 
3. Describe the steps to reproduce the problem. 
4. Supply System event logs from all machines participating in the Melio cluster. 
5. Supply the exact error message(s). 
6. Specify how many times the problem has occurred. 
7. State the actual results. 
8. Describe the expected results. 
 

1. Supply information on your hardware and software  
 

Use the All programs-> Accessories-> System tools -> System information or other product that will 
give details about the software and hardware being run on the system. 
Please describe the configuration of your central storage. Specify the type and speed of the 
connection to the hosts, the type of the disk array - JBOD or RAID, the model of the hard disks. Also 
describe the RAID controller, the RAID level, type of RAID (hardware/software), what software 
achieves the RAID functionality (Windows or third-party). Describe the topology of your storage area 
network (i.e., number of hosts, disk arrays, Fibre Channel, iSCSI, Infiniband, mpio, etc.). 
 
 

2. Supply Melio version 
 

The version of Melio can be obtained by using the Melio configuration tool. Launch the tool, select 
from the menu Help- >About and write down the driver information at the bottom of the message box. 
Please make sure that you run the same version of Melio on all your machines. If for some reason this 
is not the case, please state the version of Melio on each of the machines. 
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3. Describe the steps to reproduce the problem 
 

Please write down the exact steps that led to the problem. If Sanbolic Technical Support is unable to 
reproduce the problem, it may be difficult to identify, investigate and fix the problem. 
 
Due to the distributed nature of Melio, you will have to include some additional information as well. 
Take notes of the order in which machines were started - this directly corresponds to the order they 
enter the cluster and also affects some other aspects of Melio operation. 
 

4. Supply System event logs 
 

Please send system and application event logs from all your systems forming a cluster. Melio writes its 
information in the System event log, but other software (e.g. MS SQL) enters important information in 
the Application event log. The event logs should be in native binary format (not as text files). To do so, 
perform the following steps: 
 

�  Launch Event viewer (Start menu -> Run... -> type "eventvwr" without the quotes) 
�  Select System Log, from the ‘Action’ menu select ‘Save Log File as…’ Make sure the type of 

the file is “Event Log (*.evt(x))”. 
�  Choose "Event Log (*.evt(x))" type of the log while saving. 

 
To help Sanbolic Technical Support get as much information as possible out of log files, please 
provide the approximate time the issue occurred. 
 

5. Supply the error message(s) 
 

If an error message is displayed in a message box, write down the exact text of the message. Please 
translate the text into English, if the message is in some other language. Also you may perform a 
screen capture of the error message as follows: 
 

A. Make sure that the error message is the active window. Press Alt+PrtScn to place a bitmap 
copy of the window in the Clipboard. 

B. Open the built-in MS Paint bitmap editor, and paste the image. 
C. Go to "File->Save as" and choose a filename. 

 
In case a STOP error occurs that leads to a "blue screen of death", it is important to obtain the kernel 
memory dump that should be created at %SystemDrive%:\Windows\Memory.dmp. If you review the 
memory dump and suspect the STOP error may be Melio related, compress and upload the memory 
dump via the file manager in your account at http://clients.sanbolic.com or to ftp.sanbolic.com. Then 
contact support@sanbolic.com with a problem description according to the steps provided in this 
section. A Sanbolic Technical Support engineer will analyze the memory dump and offer suggestions 
to resolve the error based on his/her findings. 
 

6. Specify how many times the problem has occurred 
 

Please specify how often the issue occurs (i.e., rarely, frequently, ongoing). 
 

7. State the actual results 
 

Describe the exact results achieved during the test using quantitative values, when possible. For 
example, avoid saying just "the machine hangs". Instead say something along the lines of "Windows 
Explorer stopped responding (hanged), we waited for X minutes, nothing changed, we had to kill the 
explorer process". 
 

8. Describe the expected results 
 

Please describe in detail the expected test results. 
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Sanbolic Inc. 
 
Technical support: 
 
   Online: http://www.sanbolic.com/support/index.php 
   Email: support@sanbolic.com 
   Phone: U.S.: 1-800-329-0223 International: +44 20 70 99 20 34 
 
Sales inquiries: sales@sanbolic.com 
 
Web site: www.sanbolic.com 
 
Mailing address: 
 
Sanbolic, Inc. 
309 Waverly Oaks, Suite #101 
Watertown, MA 02452 
USA 

 


